hide handkerchief HDU - 2104

F - hide handkerchief Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends. 
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes . 
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A. 
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input

There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output

For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input

3 2
-1 -1

Sample Output

YES
题意:几个人围绕成一个圈丢手绢,一个人去找,他每次找下一个人的时候会隔m-1个人,问最后能否找到手绢,其实就是看能否全部遍历
 思路:一开始我就是开个简单的数组然后循环遍历,并开个数组book标记那些找过了,然后遍历看是否有未被遍历的,提交后发现MLE。
看了别人的博客才知道用最大公约数求解 如果两个数的最大公约数不为1的话 他经过一定周期后一定会回到原来的位置而其他的位置还未访问过;
 看到别人博客上的例子:容易理解,特附上
举个例子  :5 和 2 标号为1 2 3 4 5  先从1开始 依次为1~3~5~2~4~1 结束
 6 4 标号为1 2 3 4 5 6  1~5~3~1 后面就一直循环了 而 2 4 6 还没有访问过
简单的辗转相除法求最大公约数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    int n,m,flag;
    while(~scanf("%d %d",&n,&m))
    {
        flag=0;
        if(m==-1&&n==-1)
        {
            break;
        }
        if(m>n)
        {
            int temp=m;
            m=n;
            n=temp;
        }
        int r=n%m;
        while(r)
        {
            n=m;
            m=r;
            r=n%m;
        }
        if(m==1)
        {
            flag=1;
        }
        if(flag==1)
            printf("YES\n");
        else
            printf("POOR Haha\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值