hdu—1005 Number Sequence

找规律

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87139    Accepted Submission(s): 20721


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 
解题思路:
如果这个题目只是没有优化,只是简单的以为就是递归的话,肯定会导致栈溢出,好像其他暴力模拟也会超时超内存吧。
这种题应该是有规律可以寻找的,也就是说有循环节的存在。对于公式 f[n] = A * f[n-1] + B * f[n-2]; 后者只有7 * 7 = 49 种可能,为什么这么说,因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过时,循环节就出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以轻松解决了。
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1000
int f[maxn];
int main()
{
    int a,b,i,j,flag,beg,end;
    __int64 n;
    while(~scanf("%d%d%I64d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0)
            break;
        memset(f,0,sizeof(f));
        f[0]=f[1]=f[2]=1;
        flag=0;
        for(i=3;i<=n,!flag;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            for(j=2;j<=i-1;j++)
            {
                if(f[i]==f[j]&&f[i-1]==f[j-1])//寻找循环节
                {
                    beg=j;//记录循环节开始的位置
                    end=i;//记录循环节结束的位置
                    flag=1;
                    break;
                }
            }
        }
        if(flag)
        {
            printf("%d\n",f[beg+(n-beg)%(end-beg)]);//关键是这个公式,不过应该挺好理解的吧,挺简单的
        }
        else
        {
            printf("%d\n",f[n]);//这种情况就是为了防止,f[n]出现的位置没有在循环节中
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值