Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 175727 Accepted Submission(s): 43428
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
ZJCPC2004
一开始看见题目就拿着递归来做,忽略了将递归的层数,(在网上看见前辈们的分析,感受到了要想AC没那么简单)本题关键在于分析出 f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7的范围,由于mod算法的特性,结果只有0~6七种结果,f(n-1)和f(n-2)二者的组合只有49种
#include<stdio.h>
int a, b, n, f[50];
int main()
{
f[1] = f[2] = 1;
while (scanf("%d%d%d",&a,&b,&n)!=EOF)
{
if (a == 0 && b == 0 && n == 0)
continue;
for (int i = 3; i <49; i++)
{
f[i] = (a*f[i - 1] + b*f[i - 2]) % 7;
}
printf("%d\n", f[n % 49]);
}
return 0;
}