hdu 2120 Ice_cream's world I

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1072    Accepted Submission(s): 638


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
      
      
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
      
      
3
 

Author
Wiskey
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2122  2118  2119  2121  2117 
 

Statistic |  Submit |  Discuss |  Note

并查集都有固定模板,只是在某些函数中稍做改动,此例中为cycle() 中if{ num++;}else Union();
#include<stdio.h>
int n,m;
int b[1003];//顶点 n
struct edge{
	int u,v;
}a[10003];//边 m,不要定义错了,范围 
void ufset(){
	for(int i=0;i<n;i++)
	 b[i]=-1;
}
int find(int x){//并查集 固定模板:ufset find Union 
	int s;
	for(s=x;b[s]>=0;s=b[s]);
	while(s!=x){
		int temp=b[x];
		b[x]=s;
		x=temp;
	}
	return s;
}
void Union(int R1,int R2){
	int r1=find(R1),r2=find(R2);
	if(b[r1]<b[r2]){
		b[r1]+=b[r2];
		b[r2]=r1;
	}
	else {
		b[r2]+=b[r1];
		b[r1]=r2;
	}
}
void cycle(){
	int num=0,i,j;
	ufset();
	for(i=0;i<m;i++){
		int u=a[i].u,v=a[i].v;
		if(find(u)==find(v)){//u,v根相同时才计数,否则合并为一个集合 
			num++;
			//printf("u:%d v:%d ",u,v);
		}
		else Union(u,v);
	}
	printf("%d\n",num);//输出环数 
}
int main(){
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF){
		for(i=0;i<m;i++){
			scanf("%d%d",&a[i].u,&a[i].v);
		}
		cycle();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值