dijkstra+dfs

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5923    Accepted Submission(s): 2178


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
  
  
2 4
第一次以为是求最短路的条数,写了个自己很满意的代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1001;
const int INF = 0x7fffffff;
int dist[maxn];
int graph[maxn][maxn];
int cnt[maxn];
bool vis[maxn];

void dijkstra(int& n)
{
    for (int i = 1; i <= n; i ++) {
        vis[i] = false, cnt[i] = 0, dist[i] = INF;
    }
    dist[1] = 0, cnt[1] = 1;
    int minc, pos;
    for (int i = 1; i <= n; i ++) {
        minc = INF, pos = -1;
        for (int j = 1; j <= n; j ++) {
            if (!vis[j] && dist[j] < minc) {
                minc = dist[j], pos = j;
            }
        }
        if (pos == -1) return;
        vis[pos] = true;
        for (int j = 1; j <= n; j ++) {
            if (!vis[j] && graph[pos][j] != INF) {
                if (dist[j] > dist[pos]+graph[pos][j]) {
                    dist[j] = dist[pos]+graph[pos][j];
                    cnt[j]  = cnt[pos];
                } else if (dist[j] == dist[pos]+graph[pos][j]) {
                    cnt[j] += cnt[pos];
                }
            }
        }
    }
}
int main() {
   int n, m;
   while (scanf("%d", &n), n) {
    scanf("%d", &m);
    int x, y, cost;
    for (int i = 1; i <= n; i ++) {
        for (int j = 1; j <= n; j ++) {
            graph[i][j] = INF;
        }
    }
    for (int i = 0; i < m; i ++) {
        scanf("%d%d%d", &x, &y, &cost);
        graph[x][y] = graph[y][x] = cost;
    }
    dijkstra(n);
    printf("%d\n", cnt[2]);
   }
return 0;
}

然后就是WA,看了别人的才知道,不是求最短路的条数,如果有一条A到B的路,并且A到终点的路径大于B到终点的路径,那么就走A到B。
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 1001;
const int INF = 0x7fffffff;
int graph[maxn][maxn];
int dist[maxn];
int p[maxn];
bool vis[maxn];

void dijkstra(int& n)
{
    for (int i = 1; i <= n; i ++) {
        dist[i] = INF, vis[i] = 0;
    }
    dist[2] = 0;
    int minc, pos;
    for (int i = 1; i <= n; i ++) {
        minc = INF, pos = -1;
        for (int j = 1; j <= n; j ++) {
            if (!vis[j] && dist[j] < minc) {
                minc = dist[j], pos = j;
            }
        }
        vis[pos] = true;
        for (int j = 1; j <= n; j ++) {
            if (!vis[j] && graph[pos][j] != INF && dist[j] > dist[pos]+graph[pos][j])
            {
                dist[j] = dist[pos]+graph[pos][j];
            }
        }
    }
}

int dfs(int s, int n)
{
    if (p[s]) return p[s];
    if (s == 2) return 1;
    int sum = 0;
    for (int i = 1; i <= n; i ++) {
        if (graph[s][i] < INF && dist[i] < dist[s]) {
            if (p[i]) sum += p[i];
            else
                sum += dfs(i, n);
        }
    }
//    sum += p[s];
    p[s] = sum;
    return p[s];
}
int main()
{
    int n, m, x, y, w;
    while (scanf("%d", &n), n)
    {
        memset(p, 0, sizeof(p));
        for (int i = 1; i <= n; i ++) {
            for (int j = 1; j <= n; j ++) {
                if (i == j) graph[i][j] = 0;
                else
                    graph[i][j] = INF;
            }
        }
        scanf("%d", &m);
        for (int i = 0; i < m; i ++) {
            scanf("%d%d%d", &x, &y, &w);
            graph[x][y] = graph[y][x] = w;
        }
        dijkstra(n);
        cout << dfs(1,n)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值