2016 Multi-University Training Contest 2 La Vie en rose



Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string  p=p1p2...pm . So, he wants to generate as many as possible pattern strings from  p  using the following method:

1. select some indices  i1,i2,...,ik  such that  1i1<i2<...<ik<|p|  and  |ijij+1|>1  for all  1j<k .
2. swap  pij  and  pij+1  for all  1jk .

Now, for a given a string  s=s1s2...sn , Professor Zhang wants to find all occurrences of all the generated patterns in  s .
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n105,1mmin{5000,n})  -- the length of  s  and  p .

The second line contains the string  s  and the third line contains the string  p . Both the strings consist of only lowercase English letters.
 

Output
For each test case, output a binary string of length  n . The  i -th character is "1" if and only if the substring  sisi+1...si+m1  is one of the generated patterns.
 

Sample Input
  
  
3 4 1 abac a 4 2 aaaa aa 9 3 abcbacacb abc
 

Sample Output
  
  
1010 1110 100100100
 

Author
zimpha
 

Source


暴力水过
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char a[100005],b[5005];
int ans[100005],vis[5005];
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        memset(ans,0,sizeof ans);
        memset(vis,0,sizeof vis);
        scanf("%d%d",&n,&m);
        scanf("%s%s",a,b);
        for(int i=0;i<n;)
        {
            int per=i+1;
            for(int j=0;j<m;)
            {
                if(a[i]==b[j])
                {
                    i++,j++;
                }
                else if(a[i]==b[j+1]&&a[i+1]==b[j]&&j<m&&i<n)
                {
                    i+=2;
                    j+=2;
                }
                else if(a[i]!=b[j])
                {
                    i=per;
                    break;
                }
                if(j==m)
                {
                    i=per;
                    ans[per-1]=1;
                }
            }
        }
        for(int i=0;i<n;i++)
        {
            printf("%d",ans[i]);
        }
            printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值