搜索 H题

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
2.解题思路:
    题意:找出任意一个由0和1组成的数,而且是n的倍数。
同余模定理:

 a*b)%n = (a%n *b%n)%n;

 a+b)%n = (a%n +b%n)%n;

 前几个数字为:1 、10 、11、100、101、110、111、1000...

 1110%6=(110*10+0)%6=((110%6)*10)%6+(0%6);

 mod[x]=(mod[x/2]*10+x%2)%n;

3.代码:

#include<iostream>
#include<iomanip>
#include<stdio.h>
#define N 600000
using namespace std;
int mod[N];
int ans[200];
int main()
{
    int i,k,n;
    while(cin>>n&&n!=0)
    {
        mod[1]=1%n;
        for(i=2;mod[i-1]!=0;i++)
        {
            mod[i]=(mod[i/2]*10+i%2)%n;
        }
        i--;
        k=0;
        while(i)
        {
            ans[k++]=i%2;
            i/=2;
        }
        for(i=k-1;i>=0;i--)
        cout<<ans[i];
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值