搜索 I题

Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033 
1733 
3733 
3739 
3779 
8779 
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
2.解题思路:
   题意:给定两个素数n和m,要求把n变成m,每次变换时只能变一个数字,即变换后的数与变换前的数只有一个数字不同,并且要保证变换后的四位数也是素数。求最小的变换次数;如果不能完成变换,输出Impossible。

思路:首先可以确定个位数字一定是奇数(个位数字为偶数肯定不是素数),这样枚举个位数字时只需枚举奇数就行;千位数字不能是0。所以可以用广搜,枚举各个数位上的数字,满足要求的数就加入队列,直到变换成功。因为是广搜,所以一定能保证次数最少。

3.代码:
#include <iostream>
#include <string.h>
#include <math.h>
#include <queue>
using namespace std;
int main()
{
    int i,n,x,y,a,b,d,t,k,j;
    int p[10005],f[10005],w[4];
    for(i=2;i<10005;i++)
  { k=-1;
    for(j=2;j<=sqrt(i);++j)
    { if(i%j==0)
 {
 k=-2;
      break;
 }
    }
    p[i]=k;
  }
    cin>>n;
    while(n--)
{
        cin>>x>>y;
        memcpy(f,p,10005*sizeof(int));
        f[x]=0;
        queue<int>q;
        q.push(x);
        while (!q.empty()&&(f[y]==-1))
        {
            t=q.front();
            a=t;
            q.pop();


            for (i=0;i<=3;i++)
{
 w[i]=a%10;
 a/=10;
}


            for (i=0;i<=9;i++)
            {
                a=i+10*w[1]+100*w[2]+1000*w[3];
                if (f[a]==-1) {
                    f[a]=f[t]+1;
                    q.push(a);
                }
            }


            for (i=0;i<=9;i++)
            {
                a=w[0]+10*i+100*w[2]+1000*w[3];
                if (f[a]==-1) {
                    f[a]=f[t]+1;
                    q.push(a);
                }
            }
            for (i=0;i<=9;i++)
            {
                a=w[0]+10*w[1]+100*i+1000*w[3];
                if (f[a]==-1) {
                    f[a]=f[t]+1;
                    q.push(a);
                }
            }
            for (i=1;i<=9;i++)
            {
                a=w[0]+10*w[1]+100*w[2]+1000*i;
                if (f[a]==-1) {
                    f[a]=f[t]+1;
                    q.push(a);
                }
            }


        }
        if (f[y]!=-1) cout<<f[y]<<endl;
else cout<<"Impossible"<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值