poj Silver Cow Party

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18103 Accepted: 8285

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


用dij求俩次,一次是求目标到所有点的最小值,一次是求所有的点到目标的最小值,因为是单向的所以可以通过转置来进行转换

非常巧妙,不然还需要一个一个模拟所有点到目标,通过转置就把路径的方向更改了


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1100;
int a[N][N], dis[N], sum[N], visit[N];
int n, m, x;
const int inf = 1100000;


int main()
{
    while(scanf("%d %d %d", &n, &m, &x)!=EOF)
    {
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                a[i][j]=inf;
            }
        }
        for(int i=0;i<m;i++)
        {
            int c, b, w;
            scanf("%d %d %d", &c, &b, &w);
            a[c][b]=w;
        }
        for(int i=1;i<=n;i++)
        {
            dis[i]=a[x][i];
        }
        memset(visit,0,sizeof(visit));
        visit[x]=1;
        for(int i=1;i<n;i++)
        {
            int u, Min=inf;
            for(int j=1;j<=n;j++)
            {
                if(visit[j]==0&&dis[j]<Min)
                {
                    u=j;
                    Min=dis[j];
                }
            }
            if(Min==inf)
            {
                break;
            }
            visit[u]=1;
            for(int j=1;j<=n;j++)
            {
                if(visit[j]==0&&dis[u]+a[u][j]<dis[j])
                {
                    dis[j]=dis[u]+a[u][j];
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(dis[i]!=inf)
            {
                sum[i]+=dis[i];
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=i;j<=n;j++)
            {
                int tmp;
                tmp=a[i][j],a[i][j]=a[j][i],a[j][i]=tmp;
            }
        }
        for(int i=1;i<=n;i++)
        {
            dis[i]=a[x][i];
        }
        memset(visit,0,sizeof(visit));
        visit[x]=1;
        for(int i=1;i<n;i++)
        {
            int u, Min=inf;
            for(int j=1;j<=n;j++)
            {
                if(visit[j]==0&&dis[j]<Min)
                {
                    u=j;
                    Min=dis[j];
                }
            }
            if(Min==inf)
            {
                break;
            }
            visit[u]=1;
            for(int j=1;j<=n;j++)
            {
                if(visit[j]==0&&dis[u]+a[u][j]<dis[j])
                {
                    dis[j]=dis[u]+a[u][j];
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(dis[i]!=inf)
            {
                sum[i]+=dis[i];
            }
        }
        int Max=-1;
        for(int i=1;i<=n;i++)
        {
            Max=max(Max,sum[i]);
        }
        printf("%d\n",Max);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值