poj 3268 Silver Cow Party (spfa )

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12913 Accepted: 5778

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


题目是让求所有点到目标地点的最短路中的最大值。

思路:用两个二维数组分别存边的信息,两次dijkstra求得最短路。也可以用spfa求,速度很慢。

#include"stdio.h"
#include"string.h"
#define N 1005
const int inf=0x7fffffff;
int n,m,x;
int g1[N][N],g2[N][N];
int dis1[N],dis2[N],mark[N];
void dijkstra(int g[N][N],int *dis)
{
    int i,u,min;
    for(i=1;i<=n;i++)
    {
        dis[i]=inf;
        mark[i]=0;
    }
    dis[x]=0;
    while(1)
    {
        u=0;
        min=inf;
        for(i=1;i<=n;i++)
        {
            if(min>dis[i]&&!mark[i])
            {
                min=dis[i];
                u=i;
            }
        }
        if(u==0)
            break;
        mark[u]=1;
        for(i=1;i<=n;i++)
        {
            if(g[u][i]<inf&&dis[i]>dis[u]+g[u][i])
                dis[i]=dis[u]+g[u][i];
        }
    }
}
int main()
{
    int i,j,u,v,w;
    while(scanf("%d%d%d",&n,&m,&x)!=-1)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
                g1[i][j]=g2[i][j]=inf;
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            g1[u][v]=w;
            g2[v][u]=w;
        }
        dijkstra(g1,dis1);
        dijkstra(g2,dis2);
        int ans=0;
        for(i=1;i<=n;i++)
        {
            int t=dis1[i]+dis2[i];
            ans=ans>t?ans:t;
        }
        printf("%d\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值