POJ 2010(二分最大化中间值)

Time Limit: 1000MS Memory Limit: 30000KB 64bit IO Format: %lld & %llu

 Status

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 

这题真的要对贪心和二分思想掌握的非常透彻。。。

分别将cows和cowc按照s和c排序。

我的代码里check函数的返回值含义如下:

-1 直接输出,不可能满足条件了

0 这种方案是满足条件的,可以把中位数调大试试

1 这种方案是不满足的,但是把中位数调大就有可能满足了(否则不可能满足)

2 这种方案是不满足的,但是把中位数调小就有可能满足了(否则不可能满足)

还是不会用cpp,用了switch语句却没写break,导致纠结了好长时间。

终于给家里台式机装上Ubuntu了,才发现NOI Linux就是害人用的啊。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n, c, f;
const int N = 100010;
struct node1
{
    int id, s, c;
}cows[N];


struct node2
{
    int id, s, c;
}cowc[N];


int cmp1(node1 a,node1 b)
{
    return a.s<b.s;
}


int cmp2(node2 a,node2 b)
{
    return a.c<b.c;
}


int judge(int x);


int main()
{
    while(scanf("%d %d %d", &n, &c, &f)!=EOF)
    {
        for(int i=0;i<c;i++)
        {
            scanf("%d %d", &cows[i].s, &cows[i].c);
        }
        sort(cows,cows+c,cmp1);
        for(int i=0;i<c;i++)
        {
            cowc[i].s=cows[i].s, cowc[i].c=cows[i].c;
            cowc[i].id=i;
        }
        sort(cowc,cowc+c,cmp2);
        int l=0, r=c-1, mid, ans=-1;
        while(l<=r)
        {
            mid=(l+r)/2;
            int k=judge(mid);
            if(k==-1)
            {
                break;
            }
            else if(k==1)
            {
                l=mid+1;
            }
            else if(k==2)
            {
                r=mid-1;
            }
            else
            {
                l=mid+1;
                ans=cows[mid].s;
            }
        }
        if(ans==-1)
        {
            printf("-1\n");
        }
        else
        {
            printf("%d\n",ans);
        }
    }
    return 0;
}


int judge(int x)
{
    int sum=cows[x].c, l=0, r=0, m=n/2;
    for(int i=0;i<c;i++)
    {
        if(cowc[i].id<x&&l<m&&cowc[i].c+sum<=f)
        {
            sum+=cowc[i].c;
            l++;
        }
        else if(cowc[i].id>x&&r<m&&cowc[i].c+sum<=f)
        {
            sum+=cowc[i].c;
            r++;
        }
    }
    if(l<m&&r<m)
    {
        return -1;
    }
    else if(l<m)
    {
        return 1;
    }
    else if(r<m)
    {
        return 2;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值