poj 2411 Mondriaan's Dream(状压DP->求铺方格的方法数)@

Mondriaan's Dream
Time Limit:10000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 



Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare! 


Input

The input file contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11. 

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times. 

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

应该算是状压DP的启蒙题了吧

给一个矩形求用1*2的长方形将其填满的方法数

#include <algorithm>
#include <string.h>
#include <iostream>
#include <stdio.h>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
using namespace std;
typedef long long LL;
const LL mod = 1e9+7;
LL dp[20][1<<14];
int n, m;
void dfs(int i,int j,int state,int next)
{
    if(j==n)
    {
        dp[i+1][next]+=dp[i][state];
        return ;
    }
    if((state&(1<<j))==0) dfs(i,j+1,state,next|(1<<j));
    if((state&(1<<j))) dfs(i,j+1,state,next);
    if(j<=n-2&&((state&(1<<j)))==0&&((state&(1<<(j+1)))==0)) dfs(i,j+2,state,next);
    return ;
}

int main()
{

    while(scanf("%d %d", &n, &m),m||n)
    {
        memset(dp,0,sizeof(dp));
        dp[1][0]=1;
        for(int i=1;i<=m;i++)
        {
            for(int j=0;j<(1<<n);j++)
            {
                if(dp[i][j]) dfs(i,0,j,0);
            }
        }
        cout<<dp[m+1][0]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值