hdu 4300 Clairewd’s message(exkmp)

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7196    Accepted Submission(s): 2663


Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

Output
For each test case, output one line contains the shorest possible complete text.
 

Sample Input
  
  
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

Sample Output
  
  
abcdabcd qwertabcde


题意:给出明文到密文的对应法则,再给出一段密文加明文(明文可能缺失或没有),求最少的明文长度;

解:因为明文没有缺失,所以长度一定大于一半,将这个串当做明文串翻译成密文串与原串匹配,从一半开始枚举匹配长度,如果能够到达结尾则为最佳匹配


#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N= 1e6+10;
char s1[N], s2[N], s3[N];
int extend[N], nex[N];
void getnext(char a[],int len)
{
    int k=0, i=1;
    nex[0]=len;
    while(k+1<len&&a[k]==a[k+1])++k;
    nex[1]=k;
    k=1;
    while(++i<len)
    {
        int p=k+nex[k]-1;
        nex[i]=min(nex[i-k],max(p-i+1,0));
        while(i+nex[i]<len&&a[nex[i]]==a[i+nex[i]]) ++nex[i];
        if(i+nex[i]>k+nex[k]) k=i;
    }
    return ;
}
void exkmp(char a[],char b[],int len,int len2)
{
    getnext(a,len);
    int k=0, i=0;
    while(k<len2&&a[k]==b[k]) ++k;
    extend[0]=k;
    k=0;
    while(++i<len2)
    {
        int p=k+extend[k]-1;
        extend[i]=min(nex[i-k],max(p-i+1,0));
        while(i+extend[i]<len2&&a[extend[i]]==b[i+extend[i]]) ++extend[i];
        if(i+extend[i]>k+extend[k]) k=i;
    }
    return ;
}
char v[1000];
int main()
{
    int t, ncase=1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s %s",s1, s2);
        int len=strlen(s2);
        for(int i=0;i<26;i++) v[s1[i]-'a']='a'+i;
        for(int i=0;i<len;i++) s3[i]=s1[s2[i]-'a'];
        exkmp(s2,s3,len,len);
        int root=len;
        for(int i=len-len/2;i<len;i++)
        {
            if(extend[i]>=len-i)
            {
                root=i;
                break;
            }
        }
        for(int i=0;i<root;i++) printf("%c",s2[i]);
        for(int i=0;i<root;i++) printf("%c",v[s2[i]-'a']);
        printf("\n");
    }
    return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值