pat 1015. Letter-moving Game (35)(LCS)

1015. Letter-moving Game (35)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CAO, Peng

Here is a simple intersting letter-moving game. The game starts with 2 strings S and T consist of lower case English letters. S and T contain the same letters but the orders might be different. In other words S can be obtained by shuffling letters in String T. At each step, you can move one arbitrary letter in S either to the beginning or to the end of it. How many steps at least to change S into T?

Input Specification:

Each input file contains one test case. For each case, the first line contains the string S, and the second line contains the string T. They consist of only the lower case English letters and S can be obtained by shuffling T's letters. The length of S is no larger than 1000.

Output Specification:

For each case, print in a line the least number of steps to change S into T in the game.

Sample Input:
iononmrogdg
goodmorning
Sample Output:
8
Sample Solution:
(0) starts from iononmrogdg
(1) Move the last g to the beginning: giononmrogd
(2) Move m to the end: giononrogdm
(3) Move the first o to the end: ginonrogdmo
(4) Move r to the end: ginonogdmor
(5) Move the first n to the end: gionogdmorn
(6) Move i to the end: gonogdmorni
(7) Move the first n to the end: googdmornin
(8) Move the second g to the end: goodmorning
 
因为可以将字母放到最前面和最后面 ,那么LCS就要保证模式串匹配的是文本串的一段连续的字串

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N = 1010;
int dp[N][N], a[N];
char s1[N], s2[N];

int main()
{
    memset(dp,0,sizeof(dp));
    scanf("%s %s", s2+1, s1+1);

    int l1=strlen(s1+1), l2=strlen(s2+1);
    for(int i=1;i<=l1;i++)a[i]=l1+1;
    int ans=0;
    for(int i=1;i<=l1;i++)
    {
        for(int j=1;j<=l2;j++)
        {
            if(s1[i]==s2[j]&&j>a[i-1])
                dp[i][j]=dp[i-1][j-1]+1,a[i]=min(a[i],j);
            else if(s1[i]==s2[j])
                dp[i][j]=1,a[i]=min(a[i],j);
            else dp[i][j]=dp[i][j-1];
            ans=max(ans,dp[i][j]);
        }
    }
    printf("%d\n",l1-ans);
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值