More is better(hdu 1856)

More is better

TimeLimit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K(Java/Others)
Total Submission(s): 4897 Accepted Submission(s):1824


Problem Description
Mr Wang wants some boys to help him witha project. Because the project is rather complex, the more boyscome, the better it will be. Of course there are certainrequirements.

Mr Wang selected a room big enough to hold the boys. The boy whoare not been chosen has to leave the room immediately. There are10000000 boys in the room numbered from 1 to 10000000 at the verybeginning. After Mr Wang's selection any two of them who are stillin this room should be friends (direct or indirect), or there isonly one boy left. Given all the direct friend-pairs, you shoulddecide the best way.

Input
The first line of the input contains aninteger n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs.The following n lines each contains a pair of numbers A and Bseparated by a single space that suggests A and B are directfriends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactlyone integer equals to the maximum number of boys Mr Wang maykeep.

Sample Input
4 1 2 3 4 56 1 6 4 1 2 3 4 5 6 7 8

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(director indirect), then A and C are also friends(indirect). In the firstsample {1,2,5,6} is the result. In the second sample{1,2},{3,4},{5,6},{7,8} are four kinds of answers.

Author
lxlcrystal@TJU

Source

Recommend
lcy
#include<stdio.h>
#define MAX 10000000
long pre[MAX];
long num[10000010];
long find(long x){
    return pre[x] == x ? x: pre[x] =find(pre[x]);
}
void marge(long a, long b){
    long x = find(a);
    long y = find(b);
    if(x != y){
        pre[x] = y;
    }
}
long count (){
    long i, max = 0 ;
    for (i = 1 ; i <= 10000000 ; i++)num[i] = 0 ;
    for (i = 1 ; i <= 10000000 ; i++)num[find(i)]++ ;
    for (i = 1 ; i <= 10000000 ; i++)if (num[i] > max) max = num[i] ;
    return max ;
}
int main(){
    long n, p1, p2, i, max = 0, j, cnt;
    while(scanf("%ld", &n) !=EOF){
        for(i = 1; i <=MAX; i++)
            pre[i] =i;
        i = 1;
        while(i <=n){
            scanf("%ld%ld",&p1, &p2);
            if(find(p1)!= find(p2)){
                marge(p1,p2);
            }
            i++;
        }
        printf("%ld\n", count());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值