More is better(HDU 1856)

题目链接

题目描述

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入格式

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出格式

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

输入样例

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

输出样例

4
2

分析

本题主要考查并查集,且数据范围比较大,但考虑到边比较少所以可以通过set在每次运行结束后重置并查集,另外当n=0时,输出1,这是因为虽然没有朋友,但还可以留下单个人,以下是源代码。

源程序

#include <bits/stdc++.h>
using namespace std;
const int MAXN=1e7+5; 
int n,father[MAXN],nums[MAXN];
int find(int x)	//并查集 
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
int Union(int x,int y)	//合并,返回新根节点所在连通分量的节点数 
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		father[fx]=fy;
		nums[fy]+=nums[fx];
	}
	return nums[fy];
}
int read()
{
	int sum=0;
	char c=getchar();
	while(c<'0'||c>'9')c=getchar();
	while(c>='0'&&c<='9'){
		sum=sum*10+c-'0';
		c=getchar();
	}
	return sum;
}
int main()
{
	for(int i=1;i<MAXN;i++)	//初始化并查集 
		father[i]=i,nums[i]=1;
	while(~scanf("%d",&n)){
		int maxnum=1;	//记录连通分量最大节点数
		set<int> s;
		for(int i=1;i<=n;i++){
			int u=read(),v=read();
			maxnum=max(maxnum,Union(u,v));	 
			s.insert(u),s.insert(v); 
		} 
		printf("%d\n",maxnum);
		set<int>:: iterator it;
		for(it=s.begin();it!=s.end();it++)	//重置 
			father[*it]=*it,nums[*it]=1; 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值