POJ 1852 Ants 《挑战程序设计竞赛》1.6

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

大意:

一根木棍上有n只蚂蚁, 他们会在木棍上爬. 两只蚂蚁相遇,则同时掉头, 到达木棍边缘则掉下去. 蚂蚁初始位置确定,但是初始方向不确定.问所有蚂蚁都掉下去可能用的最短时间和最长时间

题解:

两只蚂蚁同时掉头,和两只蚂蚁擦身而过各走各的没什么区别. 所以这题就是求极值, 与蚂蚁到木棍中心的距离有关. 最短时间就是距离木棍中间最近的蚂蚁掉下去的事件, 最慢就是距离木棍中心最远的蚂蚁穿过木棍中心然后掉下去所用的时间

代码:

#include <iostream>
#include <cmath>
using namespace std;

int main() {
    int m;
    int len, n;
    cin >> m;
    while(m--) {
    cin >> len >> n;
    int Mid = 1.0*(len + 1) / 2;
    int Min = len, Max = Mid;
    int num;
    for(int i = 0; i < n; i++) {
        cin >> num;
        Min = abs(Mid - num) < abs(Mid - Min) ? min(num, len-num) : Min;
        Max = abs(Mid - num) > abs(Mid - Max) ? max(num, len-num) : Max;
    }
    cout << Min << " " << Max << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值