HDU 1757 A Simple Math Problem [矩阵快速幂]

题目链接: HDU 1757 A Simple Math Problem

Problem Description

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input

The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.

Output

For each case, output f(k) % m in one line.

Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

Sample Output

45
104

题解:

矩阵的快速幂
容易发现

f(x)=[f(x1)f(x2)f(x10)]a0a1a9

要用快速幂,就要凑成方阵的形式,观察发现 MiA=Mi+1 的形式:
f(x1)f(x2)f(x10)f(x2)f(x3)f(x10)f(x11)f(x19)a0a1a3a9100001000010010=f(x)f(x1)f(x9)f(x1)f(x2)f(x9)f(x10)f(x18)

初始矩阵M为
f(19)f(18)f(10)f(18)f(17)f(10)f(9)f(1)

x 小于20,可以用公式直接求,反正数据小,没有优化的必要。x 大于20, 只需要用初始矩阵乘以A矩阵
a0a1a3a9100001000010010

x19 次方
这里就可以用到快速幂来求解。

代码:

#include <iostream>
#include <cstring>
using namespace std;

typedef int Mat[11][11];
int k, m;
Mat A, T, M;
int a[20];

void matmul(Mat a, Mat b) {
    Mat c;
    memset(c, 0, sizeof(c));
    for (int i = 0; i < 10; i++) {
        for (int j = 0; j < 10; j++) {
            for (int k = 0; k < 10; k++) {
                c[i][j] += a[i][k]*b[k][j];
            }
            c[i][j] %= m;
        }
    }
    for (int i = 0; i < 10; i++) 
        for (int j = 0; j < 10; j++)
            a[i][j] = c[i][j];

}
int fun(int x) {
    if (x < 10) return x%m;
    else {
        int sum = 0;
        for (int i = 0; i < 10; i++) {
            if (a[i]==1) {
                sum += fun(x-(i+1));
            }
        }
        return sum%m;
    }
}

int main() {

    while (cin >> k >> m) {
        memset(A, 0, sizeof(A));
        memset(M, 0, sizeof(M));
        memset(T, 0, sizeof(T));


        for (int i = 0; i < 9; i++) {
            T[i][i+1] = 1;
        }
        for (int i = 0; i < 10; i++) {
            cin >> a[i];
            T[i][0] = a[i];
            A[i][i] = 1;
        }

        if (k < 20) {
            cout << fun(k)%m << endl;
        }
        else {

            k -= 19;
            for (int i = 0; i < 10; i++) {
                for (int j = 0; j < 10; j++) {
                    M[i][j] = fun(20-i-j-1);
                }
            }
            while (k > 0) {
                if (k&1) matmul(A, T);
                k >>= 1;
                matmul(T,T);
            }
            matmul(M, A);
            cout << M[0][0] << endl;

        }   
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值