HDU5540 Secrete Master Plan(模拟)

Secrete Master Plan

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1179    Accepted Submission(s): 694


Problem Description
Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form  2×2  matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.

 

Input
The first line of the input gives the number of test cases,  T(1T104) T  test cases follow. Each test case contains 4 lines. Each line contains two integers  ai0 and  ai1  ( 1ai0,ai1100 ). The first two lines stands for the original plan, the  3rd  and  4th  line stands for the plan Fei opened.
 

Output
For each test case, output one line containing " Case #x: y", where x is the test case number
(starting from 1) and  y  is either  "POSSIBLE" or  "IMPOSSIBLE" (quotes for clarity).
 

Sample Input
  
  
4 1 2 3 4 1 2 3 4 1 2 3 4 3 1 4 2 1 2 3 4 3 2 4 1 1 2 3 4 4 3 2 1
 

Sample Output
  
  
Case #1: POSSIBLE Case #2: POSSIBLE Case #3: IMPOSSIBLE Case #4: POSSIBLE


/*
思路:输入两组数据,每一组都是2*2的矩阵,是否可以通过第二个2*2的矩阵旋转得到第一个。
注意输入的时候,要控制下,看这个例子
1 2
3 4
旋转一次以后为
3 1
4 2
可以发现,在输入的时候输入的顺序为1,2,4,3。即2*2矩阵对应的位置,然后旋转即可。
注意旋转的最多次数,一个点只可能出现在四个位置,所以只需要旋转四次就可以了。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
#define PI acos(-1)
#define M(n, m) memset(n, m, sizeof(n));
const int INF = 1e9 + 7;
const int maxn = 1e5 + 100;
using namespace std;

int main()
{
    int a[22], b[22];
    int num;
    scanf("%d", &num);
    for (int k = 1; k <= num; k ++)
    {
        // 按照圈输入
        cin >> a[1] >> a[2] >> a[4] >> a[3];
        cin >> b[1] >> b[2] >> b[4] >> b[3];
        bool flag = false;
        for (int i = 0;i <= 4;i ++)
        {
            if (a[1] == b[1] && a[2] == b[2] && a[3] == b[3] && a[4] == b[4])
            {
                flag = true;
                printf("Case #%d: POSSIBLE\n", k);
                break;
            }
            // 交换位置
            else
            {
                int t = b[1];
                b[1] = b[2];
                b[2] = b[3];
                b[3] = b[4];
                b[4] = t;
            }
        }
        if (!flag)
            printf("Case #%d: IMPOSSIBLE\n", k);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值