UVa 1605 Building for UN 【技巧】

题目链接:

UVa 1605 Building for UN

Description:

The United Nations has decided to build a new headquarters in Saint Petersburg, Russia. It will have a form of a rectangular parallelepiped and will consist of several rectangular floors, one on top of another.
Each floor is a rectangular grid of the same dimensions, each cell of this grid is an office.
Two offices are considered adjacent if they are located on the same floor and share a common wall, or if one’s floor is the other’s ceiling.
The St. Petersburg building will host n national missions. Each country gets several offices that form a connected set.
Moreover, modern political situation shows that countries might want to form secret coalitions. For that to be possible, each pair of countries must have at least one pair of adjacent offices, so that they can raise the wall or the ceiling they share to perform secret pair-wise negotiations just in case they need to.
You are hired to design an appropriate building for the UN.

Input:

Input consists of several datasets. Each of them has a single integer number n (1 ≤ n ≤ 50) — the number of countries that are hosted in the building.

Output:

On the first line of the output for each dataset write three integer numbers h, w, and l — height, width and length of the building respectively.
h descriptions of floors should follow. Each floor description consists of l lines with w characters on each line. Separate descriptions of adjacent floors with an empty line.
Use capital and small Latin letters to denote offices of different countries. There should be at most 1 000 000 offices in the building. Each office should be occupied by a country. There should be exactly n different countries in the building. In this problem the required building design always exists.
Print a blank line between test cases.

Sample Input

4

Sample Output

2 2 2
AB
CC

zz
zz

题目大意:

设计一个包含若干层的大楼,要求每层都是一个等大的网格。若干国家在里面办公,将每个格子分配给一个国家,使任意两个不同的国家都有一对相邻的格子(相邻指同层有邻边或不同层但是正上方/正下方)。输入国家个数(不超过50个),输出大楼层数、每层的行数、列数及每层的平面图【不同国家用不同字母表示】。

解题思路:

因为对大楼层数、每层行数及列数没限制,所以我们可取共2层,每层都是n*n的,第一层第i行全是国家i,第二层第j列全是国家j就好了。

Mycode:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MAX = 10005;
const int MOD = 1e9+7;
const int INF = 0x3f3f3f3f;

char country(int c)
{
    if(c < 26)  return 'A' + c;
    else    return 'a' + c - 26;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        printf("2 %d %d\n", n, n);
        for(int i = 0; i < n; ++i)
        {
            for(int j = 0; j < n; ++j)
            {
                printf("%c", country(i));
            }
            puts("");
        }
        puts("");
        for(int i = 0; i < n; ++i)
        {
            for(int j = 0; j < n; ++j)
            {
                printf("%c", country(j));
            }
            puts("");
        }
        puts("");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值