PTA-023 输出GPLT

L1-023 输出GPLT (20 分)
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL

看题目,是不是感觉好简单呀!也就是把字符串里面的字符输出来,但是该怎么实现呢?噢噢,那还不简单,用if-else来吧!嘿嘿,就先下面一样写下来:

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    char a[10000];
    cin >> a;
    int i;
    for (i = 0; i < strlen(a);i++)
    {
        if(a[i]=='G'||a[i]=='g')
        {
            printf("G");
        }
        else if(a[i]=='P'||a[i]=='p')
        {
            printf("P");
        }
        else if(a[i]=='L'||a[i]=='l')
        {
            printf("L");
        }
        else if(a[i]=='T'||a[i]=='t')
        {
            printf("T");
        }
        else
            continue;
    }
    return 0;
}

嘿嘿大功告成!运行一下试试吧。
在这里插入图片描述

好像不对劲吧?你再仔细看看题目,按特定字符顺序输出!(GPLT)你这是啥玩意!if-else?早就超时了吧!那该怎么控制这四种字符的输入顺序呢?好难呀!怎么写呢?肯定不能像下面这样写了吧:

 if(a[i]=='g'||a[i]=='G')
            g++; 
        else if(a[i]=='p'||a[i]=='P')
            p++; 
        else if(a[i]=='l'||a[i]=='L')
            l++;
        else if(a[i]=='t'||a[i]=='T')
            t++;

肯定超时。这个时候就想到了另一个c语言里学的switch结构。与if-
else相比要快一些!

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
int main()
{
    char a[10000];
    cin >> a;
    int g = 0, p = 0, l = 0, t = 0;
    for (int i = 0; i < strlen(a); i++)
    {

        switch (a[i])
        {
        case 'g':
        case 'G':
            g++;
            break;
        case 'p':
        case 'P':
            p++;
            break;
        case 'l':
        case 'L':
            i++;
            break;
        case 't':
        case 'T':
            t++;
            break;
        }
    }
    while (g > 0 || p > 0 || l > 0 || t > 0)
    {
        if (g > 0)
        {
            cout << "G";
            g--;
        }
        if (p > 0)
        {
            cout << "P";
            p--;
        }
        if (l > 0)
        {
            cout << "L";
            l--;
        }
        if (t > 0)
        {
            cout << "T";
            t--;
        }
        if (g == 0 && p == 0 && l == 0 && t == 0)
        {
            cout << endl;
            break;
        }
    }
    return 0;
}

但是结果还是不太准确,还是不行。
算了,还是不要想那么复杂吧。就用if。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
int main()
{
    string a;
    cin >> a;
    int i, G = 0, P = 0, L = 0, T = 0;
    for (i = 0; a[i] != '\0'; i++)
    {
        if (a[i] == 'G' || a[i] == 'g')
            G = G + 1;
        if (a[i] == 'P' || a[i] == 'p')
            P = P + 1;
        if (a[i] == 'L' || a[i] == 'l')
            L = L + 1;
        if (a[i] == 'T' || a[i] == 't')
            T = T + 1;
    }
    while (G > 0 || P > 0 || L > 0 || T > 0)
    {
        if (G > 0)
            cout << "G", G--;
        if (P > 0)
            cout << "P", P--;
        if (L > 0)
            cout << "L", L--;
        if (T > 0)
            cout << "T", T--;
    }
    return 0;
}

继续加油吧!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值