hdu1393(规律)

本文介绍了如何解决一个关于奇特时钟的问题,该时钟只有分钟指针,通过投入不同面额的硬币可以使分钟指针顺时针移动。每个硬币面额d表示能使指针移动d倍当前时间的分钟数。给定初始时间s和硬币面额d,我们需要找出使分针回到0所需的最少硬币数量。当无法将分针调回0时,输出"Impossible"。提供了一个AC代码示例进行求解,主要通过循环和取模运算来判断条件并计算最小硬币数。
摘要由CSDN通过智能技术生成

Weird Clock
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5688 Accepted Submission(s): 2124

Problem Description
A weird clock marked from 0 to 59 has only a minute hand. It won’t move until a special coin is thrown into its box. There are different kinds of coins as your options. However once you make your choice, you cannot use any other kind. There are infinite number of coins of each kind, each marked with a number d ( 1 <= d <= 1000 ), meaning that this coin will make the minute hand move d times clockwise the current time. For example, if the current time is 45, and d = 2. Then the minute hand will move clockwise 90 minutes and will be pointing to 15.

Now you are given the initial time s ( 1 <= s <= 59 ) and the coin’s type d. Write a program to find the minimum number of d-coins needed to turn the minute hand back to 0.

Input
There are several tests. Each test occupies a line containing two positive integers s and d.

The input is finished by a line containing 0 0.

Output
For each test print in a single line the minimum number of coins needed. If it is impossible to turn the hand back to 0, output “Impossible”.

Sample Input
30 1
0 0

Sample Output
1

简述一下题意,给一个当前(分针)时间s和硬币面额d
硬币数量不限
如果可以用有限数量的硬币将分针调零,即输出最少所需数量
否则输出Impossible

样例计算方法为: 30/(30*1)=1枚

具体实现思路: s+=s*d;s%=60==0;
要注意s是实时更新的
一定存在可以调零的情况
并且在60以内
具体实现
AC代码:

#include<iostream>
using namespace std;
int main()
{
    int s,n,t;
    while(cin>>s>>n&&n)
    {
        int cnt=0;
        t=n;
        while(t--&&s)
        {
            s+=s*n;
            cnt++;
            while(s>=60)
                s-=60;
            if(s==0)
                {
                    cout<<cnt<<endl;
                    break;    
                }
        }
        if(s!=0)
            cout<<"Impossible"<<endl;
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值