HDU 3068 最长回文

Problem Description

给出一个只由小写英文字符a,b,c…y,z组成的字符串S,求S中最长回文串的长度.
回文就是正反读都是一样的字符串,如aba, abba等

Input

输入有多组case,不超过120组,每组输入为一行小写英文字符a,b,c…y,z组成的字符串S
两组case之间由空行隔开(该空行不用处理)
字符串长度len <= 110000

Output

每一行一个整数x,对应一组case,表示该组case的字符串中所包含的最长回文长度.

Sample Input

aaaa

abab

Sample Output

4
3

分析

马拉车模板题

代码

#include <algorithm>
#include <iostream>
#include <cstring>
#include <complex>
#include <cstdio>
#include <queue>
#include <cmath>
#include <map>
#include <set>

#define N 110005
#define INF 0x7fffffff
#define sqr(x) ((x) * (x))
#define pi acos(-1)

char ch[N << 1];
int len[N << 1];

int read()
{
    int x = 0, f = 1;
    char ch = getchar();
    while (ch < '0' || ch > '9'){if (ch == '-') f = -1; ch = getchar();}
    while (ch >= '0' && ch <= '9')  {x = x * 10 + ch - '0'; ch = getchar();}
    return x * f;
}

void manacher(char s[], int l)
{
    int L = 0;
    ch[L++] = '$';
    ch[L++] = '#';
    for (int i = 0; i < l; i++)
        ch[L++] = s[i], ch[L++] = '#';
    len[L] = 0;
    int mx = 0, p = 0;
    for (int i = 0; i < L; i++)
    {
        len[i] = mx > i ? std::min(len[2 * p - i], mx - i) : 1;
        while (ch[i + len[i]] == ch[i - len[i]]) len[i]++;
        if (i + len[i] > mx)
            mx = i + len[i], p = i;
    }
}

char s[N];

int main()
{
    while(~scanf("%s",s))  
    {  
        int L = strlen(s);  
        manacher(s, L);  
        int ans = 0;  
        for (int i = 0; i < 2 * L + 2; i++)  
        {  
            ans = std::max(ans, len[i] - 1);  
        }  
        printf("%d\n", ans);  
    }  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值