4549 M斐波那契数列

M斐波那契数列

Problem Description
M斐波那契数列F[n]是一种整数数列,它的定义如下:

F[0] = a
F[1] = b
F[n] = F[n-1] * F[n-2] ( n > 1 )

现在给出a, b, n,你能求出F[n]的值吗?

Input
输入包含多组测试数据;
每组数据占一行,包含3个整数a, b, n( 0 <= a, b, n <= 10^9 )

Output
对每组测试数据请输出一个整数F[n],由于F[n]可能很大,你只需输出F[n]对1000000007取模后的值即可,每组数据输出一行。

Sample Input
0 1 0
6 10 2

Sample Output
0
60

f(n)=a * fib(n-1) * b * fib(n)=(a * fib(n-1)%(mod-1))%mod * (b * fib(n)%(mod-1))%mod(费马小定理)

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int mod=1e9+7;
struct matrix {
     LL m[2][2];
}ans,base;

matrix multi(matrix a,matrix b) {
    matrix temp;
    for(int i=0;i<2;i++) {
        for(int j=0;j<2;j++) {
            temp.m[i][j]=0;
            for(int k=0;k<2;k++) {
                temp.m[i][j]=(a.m[i][k]*b.m[k][j]+temp.m[i][j])%(mod-1);
            }
        }
    }
    return temp;
}

LL fast_mod(LL n) {
    base.m[0][0]=base.m[0][1]=base.m[1][0]=1;
    base.m[1][1]=0;
    ans.m[0][0]=ans.m[1][1]=1;
    ans.m[0][1]=ans.m[1][0]=0;
    while(n) {
        if(n&1) ans=multi(ans,base);
        base=multi(base,base);
        n>>=1;
    }
    return ans.m[0][1]%(mod-1);
}

LL q_mod (LL x , LL n) {
    LL sum=1;
    while(n) {
        if(n&1) sum=(sum*x)%mod;
        n>>=1;
        x=(x*x)%mod;
    }
    return sum%mod;
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    LL a,b,n;
    while(cin>>a>>b>>n) {
        if(n==0) cout<<a<<endl;
        else if(n==1) cout<<b<<endl;
        else cout<<(q_mod(a,fast_mod(n-1))*q_mod(b,fast_mod(n)))%mod<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值