[kuangbin带你飞]专题四 最短路练习 A

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

  • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output
  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90

就是有T条边,让你求从1点到N点的最短距离


#include<iostream>
#include<vector>
#include<queue>
#include<utility>

using namespace std;
const int maxn = 1e4 ;
int T,N;
vector<pair<int,int> > E[maxn];//储存边和距离
int d[maxn];//点s到其他点的距离
priority_queue<pair<int,int> >Q;//储存与遍历过的点直接相连的点
void init()//初始化
{
    for(int i=0;i<=N;i++) E[i].clear();
    for(int i=0;i<=N;i++) d[i]=1e9;
    while(!Q.empty()) Q.pop();
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    cin>>T>>N;//T条边,终点为N
    init();
    for(int i=0;i<T;i++) {
        int a,b,c;
        cin>>a>>b>>c;
        E[a].push_back(make_pair(b,c));//a到b的距离为c
        E[b].push_back(make_pair(a,c));//b到a的距离为c
    }
        d[1]=0;
        Q.push(make_pair(-0,1));//优先队列从大到校排列,-d[s]的结果排出来的第一个是最小的
    while(!Q.empty()) {
            int now=Q.top().second;
            Q.pop();
            for(int i=0;i<E[now].size();i++) {
                int v=E[now][i].first;
                if(d[v]>d[now]+E[now][i].second)
                {d[v]=d[now]+E[now][i].second;
                Q.push(make_pair(-d[v],v));}
                }
                if(now==N) break;
            }
        cout<<d[N]<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值