HDU 1058 Humble Numbers

Humble Numbers

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

网上将这道题归为DP,虽然我看不到什么DP的思想….就是用四个变量来维护数组的有序性,其中学到了一个写英文第几个的方法,
if(n%10==1&&n%100!=11) cout<<”st”;
else if(n%10==2&&n%100!=12) cout<<”nd”;
else if(n%10==3&&n%100!=13) cout<<”rd”;
else cout<<”th”;
我觉得以后会用上

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int INF=0x3f3f3f3f;
LL ans[6000];

void init() {
    ans[1]=1;
    int i=1,j=1,k=1,m=1;
    for(int cnt=2;cnt<=5842;cnt++){
       ans[cnt]=min(2*ans[i],min(3*ans[j],min(5*ans[k],7*ans[m])));
       if(ans[cnt]==2*ans[i]) i++;
       if(ans[cnt]==3*ans[j])j++;
       if(ans[cnt]==5*ans[k]) k++;
       if(ans[cnt]==7*ans[m]) m++;
    }
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    init();
    int n;
    while(cin>>n&&n){
        cout<<"The "<<n;
        if(n%10==1&&n%100!=11) cout<<"st";
        else if(n%10==2&&n%100!=12) cout<<"nd";
        else if(n%10==3&&n%100!=13) cout<<"rd";
        else cout<<"th";
        cout<<" humble number is "<<ans[n]<<".\n";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值