Hdu 1074Doing Homework(状压DP)

Doing Homework

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output
2
Computer
Math
English
3
Computer
English
Math

题意是要求你完成一写作业,每份作业都有自己的截止日期和所需时间,如果晚交一天就要扣一分,问做完这些作业最少需要扣几分,这道题感觉得NP难题,好在作业数量只有16个,可以用状压DP进行状态压缩,复杂度为O(2^n*n^2),状压DP的优化就是对内存空间的优化,下面是自己的代码:

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int INF=0x3f3f3f3f;
const int maxn=1<<16;
int dp[maxn],dead[maxn],pre[maxn];
int n;
struct Node {
    string s;
    int cost,dead;
}ans[20];

void print(int num) {
    if(num==0) return ;
    print(pre[num]);
    num-=pre[num];//此时的num为一个i位是1其他位都是0的数,减去以后表示此时做这个作业是最优解
    for(int i=0;i<n;i++) {
        if(num&1<<i) cout<<ans[i].s<<endl;
    }
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    int t;
    cin>>t;
    while(t--) {
        cin>>n;
        for(int i=0;i<n;i++) cin>>ans[i].s>>ans[i].dead>>ans[i].cost;
        int sum=1<<n;
        for(int i=1;i<sum;i++) dp[i]=INF;
        dp[0]=0;
        memset(dead,0,sizeof(dead));
        memset(pre,0,sizeof(pre));
        for(int i=1;i<sum;i++) {
            for(int j=0;j<n;j++) {
                if((i&1<<j)==0) continue;//如果i对应的j位是0表示没做这个作业
                int k=i-(1<<j);//表示没做作业这个的情况
                dead[i]=dead[k]+ans[j].cost;
                int cost=dead[i]>ans[j].dead?dead[i]-ans[j].dead:0;
                if(dp[k]+cost<=dp[i]) {
                    dp[i]=dp[k]+cost;
                    pre[i]=k;
                }
            }
        }
        cout<<dp[sum-1]<<endl;
        print(sum-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值