最大子矩阵—最大子段和的推广

1031: To the Max

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array:  

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2

is in the lower left corner:

9 2 
-4 1 
-1 8

and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-128,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

Sample Output

15

HINT

Source


题意:给定一个矩阵,求其最大的一个子矩阵的和。
解题思路:想办法把其转化为一维的最大子段和:添加一个辅助数组B,用B[i][j]表示在A数组(原数组)中从A[0][j]到A[i][j]的连续和值。然后在添加一个数组C,用C[k]来存储任意两行(不妨设为i,j)之间第k列的和值,那么,i,j之间的最大子矩阵就转化为了求C数组的最大子段和(仔细想想就能明白)。思路就这样。枚举i,j为O(n^2),最大子段和为O(N),所以总的时间按复杂度为O(N^3)。
附上一个讲的比较详细的链接: 戳这里

代码:
#include<bits/stdc++.h>
#define maxn 110
#define INF 0x7fffffff
using namespace std;

int A[maxn][maxn],B[maxn][maxn],C[maxn],dp[maxn];
int N,ans;

void solve(){
    ans=-INF;
    for(int i=1;i<=N;i++)
        for(int j=i;j<=N;j++){//接下来就是用C数组模拟求最大子段和了
            for(int k=1;k<=N;k++) C[k]=B[j][k]-B[i-1][k];
            dp[0]=0;
            for(int k=1;k<=N;k++)
                dp[k]=C[k]+(dp[k-1]>0? dp[k-1]:0),ans=max(ans,dp[k]);
        }
    printf("%d\n",ans);
}

int main(){
    //freopen("in.txt","r",stdin);
    while(cin>>N){
        for(int i=1;i<=N;i++) for(int j=1;j<=N;j++)
            scanf("%d",A[i]+j);
        for(int i=0;i<=N;i++) B[0][i]=0;
        for(int j=1;j<=N;j++) for(int i=1;i<=N;i++)
            B[i][j]+=B[i-1][j]+A[i][j];//辅助求和数组
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值