An Easy Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9787 Accepted Submission(s): 6045
Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Each test case contains two positive integers Y and N(1<=N<=10000).
Output
For each test case, you should output the Nth leap year from year Y.
Sample Input
3 2005 25 1855 12 2004 10000
Sample Output
2108 1904 43236HintWe call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
Author
Ignatius.L
#include <iostream>
using namespace std;
int leapYear(int Y)
{
if((Y%4==0 && Y%100!=0) || Y%400==0)
return 1;
else
return 0;
}
int main()
{
int t, y, n, i;
cin>>t;
while (t--) {
cin>>y>>n;
while(1) {
if (leapYear(y) == 1)
break;
y++;
}
for (i = 0; i < n-1;)
{
y += 4;
if(leapYear(y) == 1)
i++;
}
cout<<y<<endl;
}
return 0;
}