HDU1076

An Easy Task

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17828 Accepted Submission(s): 11353

Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

Output
For each test case, you should output the Nth leap year from year Y.

Sample Input
3
2005 25
1855 12
2004 10000

Sample Output
2108
1904
43236

Hint

We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

Author
Ignatius.L

利用周期加速 400年一个循环 你懂的
水题又WA了好几次 心好累

#include "cstring"
#include "string.h"
#include "cstdio"
#include "iostream"


using namespace std;

int ans[500];

int main()
{
    int n;
    int newcount = 0;
    for (int i = 1; i <= 400; i++)
    {
        if ((i % 4 == 0 && (i % 100) != 0) || i % 400 == 0)
        {
            newcount++;
            ans[i] = newcount;
        }
        else
            ans[i] = newcount;

    }

    while (scanf("%d", &n)!=EOF)
    {
        while (n--)
        {
            int th;
            int year;
            scanf("%d %d", &year, &th);
            int originleapyear = (year / 400)*ans[400] + ans[(year % 400)];
            int temp = th / ans[400];
            int nowyear = year + 400 * temp;
            int count = 97 * (temp-1);
            for (int i = nowyear-400; i <= nowyear+400; i++)
            {
                if (count == th)
                {
                    printf("%d\n", i - 1);
                    break;
                }

                if ((i % 4 == 0 && (i % 100) != 0) || i % 400 == 0)
                {
                    count++;
                }
            }
        }

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值