1014. Waiting in Line (30)

题目要求:

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry
分析:

这一题的解题思路的关键就是每次一个新的人进入黄线内时,每一队当前排头谁最先完成process,这个人就进入哪一队。然后每个人的时间就是他前面所有人的时间和在加上他自己的处理时间。因此我用队列处理的,每个窗口一个队列,每次检查队列排头的时间(累计时间),那个最小便将其出队,新的人入队。

另外需要注意的地方就是Sorry的客户只有在17点之后入队的人,而不是谁的processed时间超过17点,比如当一个用户时间在16:59开始执行时,即便操作时间很长,依然是有效的。

由于在初始状态时,黄线内的m×n个人的完成时间是固定的,即便人数不足m×n。因此我在计算时间时将前m×n个人与后面的分开处理。但是注意到前m×n个人也存在Sorry的情况。有一个case就是检查的这个地方。

代码如下:

#include <stdio.h>

int time[1001];
int leave_time[1001];

typedef struct _queue
{
	int person[11];
	int pass_time;
	int flag_time;
	int rear,front;
}queue;

void init(queue *q)
{
	q->pass_time = q->flag_time = 0;
	q->front = q->rear  = 0;
}

void enqueue(queue *q,int p)
{
	q->pass_time += time[p];
	q->person[q->rear] = p;
	q->rear = (q->rear+1)%11;
}

void dequeue(queue *q)
{
	int res;
	q->front = (q->front+1)%11;
	res = q->person[q->front];
	q->flag_time += time[res];
}

int head(queue *q)
{
	return q->flag_time;
}

int find_min(queue *q,int n)
{
	if(n == 1)
		return 0;
	int i,min,v;
	min = 1;
	v = head(&q[1]);
	for(i=2;i<n;i++)
	{
		if(head(&q[i]) < v)
		{
			min = i;
			v = head(&q[i]);
		}
	}
	if(v>head(&q[0]))
		return 0;
	else
		return min;
}

int main(int argc,char* argv[])
{
	int i,n,m,k,q;
	int num,count,min;
	queue qu[21];

	scanf("%d%d%d%d",&n,&m,&k,&q);

	for(i=1;i<=k;i++)
		scanf("%d",&time[i]);

	for(i=0;i<21;i++)
		init(&qu[i]);

	for(i=1;i<=k;i++)
		leave_time[i] = 0;

	//compute first m*n person
	for(i=1;i<=n*m;i++)
	{
		if(qu[i%n].pass_time >= 540)
			leave_time[i] = -1;
		else{
			enqueue(&qu[i%n],i);
			leave_time[i] = qu[i%n].pass_time;
		}
	}

	//compute the rest person
	for(i=1;i<=n;i++)
		qu[i%n].flag_time = time[i];
	for(i=n*m+1;i<=k;i++)
	{
		min = find_min(qu,n);
		if(qu[min].pass_time >= 540)
			leave_time[i] = -1;
		else{
			enqueue(&qu[min],i);
			dequeue(&qu[min]);
			leave_time[i] = qu[min].pass_time;
		}
	}

	//print
	for(i=0;i<q;i++)
	{
		scanf("%d",&num);
		if(leave_time[num] != -1)
			printf("%02d:%02d\n",leave_time[num]/60+8,leave_time[num]%60);
		else
			printf("Sorry\n");

	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值