1032. Sharing (25)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
这一题由于不用输出字符,所以可以完全忽略掉每个地址所代表的字符是什么。解题的思路主要在后缀检查,因为两个字符串如果共享存储,一定是字符串的最后一部分,所以需要对两个字符串从后往前进行过滤,直到找到不同的地址。由于地址的输入顺序是随机的,而且next存储的是下一项的地址,而这个地址不能直接取址,所以用一个数组作为hash模拟了内存取址的原理,让数组的下表为地址大小,数组的内容作为下一项的地址,这样每次next的时候很快,可以节省时间,但是缺点就是浪费内存。
接下来就是开了两个数组依次存储每个字符的地址,然后从两个数组的最后一个元素开始比较,直到找到不同的部分。
在过滤的时候用了一个哨兵——第一个地址数组的末尾添加了一个-1,那么不管有没有字符是共享的,都取该元素的下一项。
最后有可能一个字符串是另外一个的字串,需要追加考虑。
代码如下
#include <stdio.h>
#include <stdlib.h>

#define PRINT_I(x) printf("%s = %d\n",#x,x);
#define PRINT_F(x) printf("%s = %f\n",#x,x);
#define PRINT_S(x) printf("%s = %s\n",#x,x);

int main(int argc,char* argv[])
{
	int i,j,n,head1,head2,share;
	int address,next,size1,size2;
	char c;
	int node[100000] = {0};
	int addr1[100000],addr2[100000];

	//freopen("input","r",stdin);

	scanf("%d%d%d",&head1,&head2,&n);

	for(i=0;i<n;i++)
	{
		scanf("%d %c %d",&address,&c,&next);
		node[address] = next;
	}

	size1 = size2 = 0;

	while(head1 != -1)
	{
		addr1[size1++] = head1;
		head1 = node[head1];
	}
	while(head2 != -1)
	{
		addr2[size2++] = head2;
		head2 = node[head2];
	}

	addr1[size1] = -1;
	i = size1-1;
	j = size2-1;
	while(i>=0&&j>=0)
	{
		if(addr1[i] != addr2[j])
		{
			share = addr1[i+1];
			break;
		}
		i--;
		j--;
	}

	if(i == -1)
		share = addr1[0];
	if(j == -1)
		share = addr2[0];
	if(share > 0)
		printf("%05d\n",share);
	else
		printf("-1\n");

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值