spoj 104 Highways

SPOJ - HIGH

Time Limit: 7000MS Memory Limit: 1572864KB 64bit IO Format: %lld & %llu

Status

Description

In some countries building highways takes a lot of time... Maybe that's because there are many possiblities to construct a network of highways and engineers can't make up their minds which one to choose. Suppose we have a list of cities that can be connected directly. Your task is to count how many ways there are to build such a network that between every two cities there exists exactly one path. Two networks differ if there are two cities that are connected directly in the first case and aren't in the second case. At most one highway connects two cities. No highway connects a city to itself. Highways are two-way.

Input

The input begins with the integer t, the number of test cases (equal to about 1000). Then t test cases follow. The first line of each test case contains two integers, the number of cities (1<=n<=12) and the number of direct connections between them. Each next line contains two integers a and b, which are numbers of cities that can be connected. Cities are numbered from 1 to n. Consecutive test cases are separated with one blank line.

Output

The number of ways to build the network, for every test case in a separate line. Assume that when there is only one city, the answer should be 1. The answer will fit in a signed 64-bit integer.

Example

Sample input:
4
4 5
3 4
4 2
2 3
1 2
1 3

2 1
2 1

1 0

3 3
1 2
2 3
3 1

Sample output:
8
1
1
3

Input

Output

Sample Input

Sample Output

Hint

Added by:Piotr Łowiec
Date:2004-07-02
Time limit:7s
Source limit:50000B
Memory limit:1536MB
Cluster:Cube (Intel Pentium G860 3GHz)
Languages:d

All except: SCM chicken




Matrix-Tree定理(Kirchhoff矩阵-树定理)。Matrix-Tree定理是解决生成树计数问题最有力的武器之一。它首先于1847年被Kirchhoff证明。在介绍定理之前,我们首先明确几个概念:

1、G的度数矩阵D[G]是一个n*n的矩阵,并且满足:当i≠j时,dij=0;当i=j时,dij等于vi的度数。

2、G的邻接矩阵A[G]也是一个n*n的矩阵, 并且满足:如果vi、vj之间有边直接相连,则aij=1,否则为0。

我们定义G的Kirchhoff矩阵(也称为拉普拉斯算子)C[G]为C[G]=D[G]-A[G],则Matrix-Tree定理可以描述为:G的所有不同的生成树的个数等于其Kirchhoff矩阵C[G]任何一个n-1阶主子式的行列式的绝对值。所谓n-1阶主子式,就是对于r(1≤r≤n),将C[G]的第r行、第r列同时去掉后得到的新矩阵,用Cr[G]表示。


      

代码里面包含了求Kirchhoff矩阵C[G]的一个n-1阶主子式的行列式的绝对值的模板。







#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<utility>
//#pragma comment(linker, "/STACK:102400000,102400000")
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,l,mid
#define rson    num<<1|1,mid+1,r
#define MID   int mid=(l+r)>>1
#define zero(x)((x>0? x:-x)<1e-15)
using namespace std;
const int maxn=   12+3 ;
//const int maxm=    ;
//const int INF=    ;
//typedef long long ll;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);

int d[maxn][maxn];
int  a[maxn][maxn];
double b[maxn][maxn];
double Kir[maxn][maxn];


double det(double a[maxn][maxn],int n)
 {

    int i, j,k, sign = 0;
    double ret = 1, t;
    for (i =0; i < n; i++)
        for(j = 0; j < n; j++)
           b[i][j] = a[i][j];

    for (i =0; i < n; i++) {
        if(zero(b[i][i])) {
           for (j = i + 1; j < n; j++)
               if (!zero(b[j][i]))
                   break;
           if (j == n)
               return 0;
           for (k = i; k < n; k++)
              swap(b[i][k],b[j][k]);
           sign++;
        }

        ret*= b[i][i];
        for(k = i + 1; k < n; k++)
           b[i][k] /= b[i][i];
        for(j = i + 1; j < n; j++)
           for (k = i + 1; k < n; k++)
               b[j][k] -= b[j][i] * b[i][k];

    }

    if (sign& 1)

        ret =-ret;

    return ret;

}

int main()
{
      int i,j,n;
      int T;int x,y;int m;
      scanf("%d",&T);
      while(T--)
      {
          scanf("%d%d",&n,&m);
          memset(a,0,sizeof a);
          memset(d,0,sizeof d);

          FOR1(i,m)  scanf("%d%d",&x,&y),x--,y--,a[x][y]=-1,a[y][x]=-1,d[x][x]++,d[y][y]++;
         FOR0(i,n)  FOR0(j,n)  Kir[i][j]=d[i][j]+a[i][j];
        double ans=det(Kir,n-1);
       printf("%.0lf\n",ans);
      }




    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值