hdu 5441 Travel 并查集 2015 ACM/ICPC Asia Regional Changchun Online

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 424    Accepted Submission(s): 183


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are  n  cities and  m  bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is  x  minutes, how many pairs of city  (a,b)  are there that Jack can travel from city  a  to  b  without going berserk?
 

Input
The first line contains one integer  T,T5 , which represents the number of test case.

For each test case, the first line consists of three integers  n,m  and  q  where  n20000,m100000,q5000 . The Undirected Kingdom has  n  cities and  m bidirectional roads, and there are  q  queries.

Each of the following  m  lines consists of three integers  a,b  and  d  where  a,b{1,...,n}  and  d100000 . It takes Jack  d  minutes to travel from city  a  to city  b  and vice versa.

Then  q  lines follow. Each of them is a query consisting of an integer  x  where  x  is the time limit before Jack goes berserk.

 

Output
You should print  q  lines for each test case. Each of them contains one integer as the number of pair of cities  (a,b)  which Jack may travel from  a  to  b  within the time limit  x .

Note that  (a,b)  and  (b,a)  are counted as different pairs and  a  and  b  must be different cities.
 

Sample Input
  
  
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
  
  
2 6 12
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5449  5448  5447  5446  5445 
 

并查集。
int main()
{
    int T,x,y,z,ww;scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&q);
        init();
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            add_edge(x,y,z);
        }
         sort(edges,edges+e_max);

        for(int i=1;i<=q;i++)
        {
            scanf("%d",&query[i].num);
            query[i].index=i;
        }

        sort(query+1,query+1+q);

        int now=1;tot=0;
          for(int i=1;i<=n;i++)
                pre[i]=i;
                
          for(int i=1;i<=n;i++)
          {
              cnt[i]=1;
          }


            for(int id=0;id<e_max&&now<=q;id++)
            {
                while(now<=q && edges[id].w>query[now].num )
                {
                    x=query[now].index;
                    ans[x]=tot;
                    now++;
                }
               if(now> q  )   break;

              x=edges[id].from;
              y=edges[id].to;
            merge(x,y);

            }

            if(now<=q)
            {
                for(int i=now;i<=q;i++)
                {
                   x=query[i].index;
                     ans[x]=tot;
                }
            }

        for(int i=1;i<=q;i++)
        {
            printf("%d\n",ans[i]);
        }

    }


    return 0;
}


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second

using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn=20000+10    ;
const int maxm=100000+20    ;
//by yskysker123
//#######################################################
int n,m,q,tot;
int pre[maxn];
int ans[maxn];
struct Edge
{
    int from,to,w;
    bool operator<(const Edge y) const
    {
        return w<y.w;
    }
    Edge(){}
    Edge(int &from,int &to,int &w):from(from),to(to),w(w){}
} edges[maxm];
int cnt[maxn],e_max;
struct Query
{
 int num,index;
 bool operator<(const Query y)const
 {
     return num<y.num;
 }
} query[5000+10];





//###################################################################
inline void add_edge(int x,int y,int w_)
{
    int e=e_max++;
    edges[e]=Edge(x,y,w_);
}
inline void init()
{

    e_max=0;
}

int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x]);
}
inline void merge(int s,int t)
{
    int r1=find(s);
    int r2=find(t);
    if(r1==r2) return;

     int x=cnt[r1];
       tot-=x*(x-1);
         x=cnt[r2];
       tot-=x*(x-1);

        pre[r1]=r2;
      int r=find(s);
      x=cnt[r]=cnt[r1]+cnt[r2];  //一开始这里写成了++

      tot+=x*(x-1);


}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值