hdu 1520 Anniversary party 基础树形DP 树的最大独立集

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7575    Accepted Submission(s): 3323


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
  
  
5
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1561  1011  2196  1494  2242 

 
题意:
给定一个树,选择若干点,使得选择的结点中任两点不相邻,求能选结点最大数量。同时判断方案数是否为一。

当初了两个while(~scanf())都都写掉了~,莫名其妙地发现TLE。

其实每组数据只会输入n个关系,其中最后一个关系都是0 0。


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI (4.0*atan(1.0))
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   ind<<1,le,mid
#define rson    ind<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
#define ysk(x)  (1<<(x))
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 6000+20   ;
//const int maxm=    ;

int n,root;
vector<int >G[maxn];
int deg[maxn];
int dp[maxn][2];
int a[maxn];
int dfs(int x,int se)
{

    int &ans=dp[x][se];
    if(ans!=-1)  return ans;
    ans=0;
    if(se)  ans+=a[x];
    for(int i=0;i<G[x].size();i++)
    {
        int y=G[x][i];
        if(se)  ans+=dfs(y,0);
        else   ans+=max( dfs(y,0),dfs(y,1) );
    }
    return ans;
}
int main()
{
   while(~scanf("%d",&n))
   {
//       if(n==0)  {scanf("%d",&n);break;}

       for(int i=1;i<=n;i++)
       {
           G[i].clear();
           deg[i]=0;
        scanf("%d",&a[i]);
       }

       int x,y;
       while(~scanf("%d%d",&x,&y)&&(x||y))
       {
           G[y].push_back(x);
           deg[x]++;
       }

       for(int i=1;i<=n;i++)
       {
           if(deg[i]==0)  root=i;
       }
       memset(dp,-1,(n+1) *sizeof dp[0]);
       printf("%d\n",max( dfs(root,0),dfs(root,1)  )  );

   }

    return 0;
}





#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI (4.0*atan(1.0))
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   ind<<1,le,mid
#define rson    ind<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
#define ysk(x)  (1<<(x))
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 6000+20   ;
//const int maxm=    ;

int n,root;
vector<int >G[maxn];
int deg[maxn];
int dp[maxn][2];
int a[maxn];
int dfs(int x,int se)
{

    int &ans=dp[x][se];
    if(ans!=-1)  return ans;
    ans=0;
    if(se)  ans+=a[x];
    for(int i=0;i<G[x].size();i++)
    {
        int y=G[x][i];
        if(se)  ans+=dfs(y,0);
        else   ans+=max( dfs(y,0),dfs(y,1) );
    }
    return ans;
}
int main()
{
   while(~scanf("%d",&n))
   {
//       if(n==0)  {scanf("%d",&n);break;}

       for(int i=1;i<=n;i++)
       {
           G[i].clear();
           deg[i]=0;
        scanf("%d",&a[i]);
       }

       int x,y;
       for(int i=1;i<=n;i++)
       {
           scanf("%d%d",&x,&y);
           G[y].push_back(x);
           deg[x]++;
       }

       for(int i=1;i<=n;i++)
       {
           if(deg[i]==0)  root=i;
       }
       memset(dp,-1,(n+1) *sizeof dp[0]);
       printf("%d\n",max( dfs(root,0),dfs(root,1)  )  );

   }

    return 0;
}

我想说的是,不用调用两次递归来求,一次递归即可。

在函数里面对dp[x][0]分别处理即可。


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值