poj 3071 Football dp(概率)


题意:给出n,2^n个队伍进行比赛。每轮两两相邻的队伍进行比赛,淘汰一半的队伍。进行n轮比赛直至剩下最后一队。

 给出对战胜率表,问那支队伍赢的概率大。(n<=7)


解:

 比赛轮数就是个天然的"序",dp[i][x]代表进行了i轮比赛后,x队还未被淘汰的概率。让编号从0开始,用位运算处理非常方便。


Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4563 Accepted: 2349

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source



#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define ysk(x)  (1<<(x))
#define end_    puts("--------end-------");
#define debug_(x)    printf("--------debug------%d:\n",x);
#define show_(x,y)    printf("dp[%d][%d]  %f\n",x,y,dp[x][y]);
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxN= 128   ;
int n,N;
double dp[9][maxN+10];
double win[maxN+5][maxN+5];

int main()
{
    while(~scanf("%d",&n)&&n!=-1)
    {
        N=pow(2,n)+0.5;
        for0(i,N)
        {
           for0(j,N)
           {
               scanf("%lf",&win[i][j]);
           }
        }

        for0(x,N)  dp[0][x]=1;
        for1(i,n)
        {
            for0(x,N)
            {
                int st=x,ed=x;
                for(int j=0;j<i-1;j++)
                {
                    st&=  ~ysk(j) ;
                    ed|=   ysk(j) ;
                }
                st^=ysk(i-1);
                ed^=ysk(i-1);
                double tot=0;
                dp[i][x]=0;
                for(int y=st;y<=ed;y++)
                {
                    dp[i][x]+= dp[i-1][x]*win[x][y]*dp[i-1][y];
                }
            }
        }
        int p=-1;double maxi=-1;
        for0(x,N)
        {
            if(dp[n][x]>maxi)
            {
                maxi=dp[n][x];
                p=x;
            }
        }
        printf("%d\n",p+1);

    }

   return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值