poj 2318 TOYS 二分+叉积

TOYS


Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13770 Accepted: 6649
Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.
Source

Rocky Mountain 2003


题意:

给出一个矩形抽屉,然后有n个板子放在其中,连接上下底。给出m个玩具的坐标(视作点),
问n+1个区间内,每个区间中有多少玩具。


解法:

首先给出的木板是从左往右排序过的,如果一个点在某个板子x左边,一定会在板子y>x 左边,所以满足单调性,二分。
然后是判断点在直线左边。

这里写图片描述


点P在直线AB左边 PA¯¯¯¯¯×PB¯¯¯¯¯<0


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn= 5000    ;
const int maxm= 5000    ;
int n,m;
double L,U,R,D;

const double PI=cos(-1.0);
struct Point
{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y) {};
    void show()
    {
        printf("Vector :x=%f y=%f\n",x,y);
    }
};
typedef Point Vector;
Vector operator +(Vector A,Vector B) {return Vector(A.x+B.x,A.y+B.y); }
Vector operator -(Vector A,Vector B) {return Vector(A.x-B.x,A.y-B.y); }
Vector operator *(Vector A,double p) {return Vector(A.x*p,A.y*p); }
Vector operator /(Vector A,double p) {return Vector(A.x/p,A.y/p); }
Vector operator -(Vector A)  {return  Vector(-A.x,-A.y);}

double torad(double deg)
{
    return deg/180*acos(-1.0);
}

const double eps=1e-10;
int dcmp(double x)
{
    if(fabs(x)<eps)  return 0;
    else return x<0?-1:1;
}


bool operator<(const Point &a ,const Point& b)
{
    return dcmp(a.x-b.x)<0|| dcmp(a.x-b.x)==0 &&dcmp(a.y-b.y)<0;
}

double Dot(Vector A,Vector B)//点乘
{
    return A.x*B.x+A.y*B.y;
}

double Length(Vector A)
{
    return sqrt(Dot(A,A));
}

double Angle(Vector A,Vector B)
{
    return acos(Dot(A,B)/Length(A)/Length(B));
}

double Cross(Vector A,Vector B)//叉乘
{
    return A.x*B.y-A.y*B.x;
}

double Area2(Point A,Point B,Point C)//平行四边形面积
{
    return Cross(B-A,C-A);
}

Vector Rotate(Vector A,double rad)//向量A 逆时针旋转rad度
{
   return Vector(A.x*cos(rad)-A.y*sin(rad),A.x*sin(rad)+A.y*cos(rad)     );
}


Vector Normal(Vector A)//计算A的单位向量
{
    double L=Length(A);
    return Vector( -A.y/L,A.x/L );
}
struct Line
{
    Point p1,p2;
    Line(){}
    Line(Point p1,Point p2):p1(p1),p2(p2){}

}li[maxn+5];

int num[maxn+5];




bool PointIsLeft(Point p,Line line)
{
    Vector v1=  line.p1-p;
    Vector v2=  line.p2-p;
    return dcmp(Cross(v1,v2))<0;
}
int bs(Point p,int le,int ri)
{
    while(le<=ri)
    {
        int mid=(le+ri)>>1;
        if(PointIsLeft(p,li[mid]) )  ri=mid-1;
        else le=mid+1;
    }
    return le;
}

void solve()
{
    Point p;
    cin>>p.x>>p.y;
    int k=bs(p,0,n-1);
    num[k]++;
}
int main()
{
   std::ios::sync_with_stdio(false);
   int kase=0;
   while(cin>>n&&n)
   {
       cin>>m>>L>>U>>R>>D;
       if(kase++)  putchar('\n');
       double x1,x2;
       for0(i,n)
       {
           cin>>x1>>x2;
           Point p1=Point(x1,U);
           Point p2=Point(x2,D);
           li[i]=Line( p1,p2  );
       }
       //区域 [0,n],线[0,n)
       mes(num,0,(n+1));
       for0(i,m)
       {
           solve();
       }
       for0(i,n+1)
       {
           printf("%d: %d\n",i,num[i]);
       }

   }

   return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值