hdu 5510 Bazinga 剪枝+find()/strstr()/KMP


Bazinga

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3123    Accepted Submission(s): 1002


Problem Description
Ladies and gentlemen, please sit up straight.
Don't tilt your head. I'm serious.

For  n  given strings  S1,S2,,Sn , labelled from  1  to  n , you should find the largest  i (1in)  such that there exists an integer  j (1j<i)  and  Sj  is not a substring of  Si .

A substring of a string  Si  is another string that occurs  in  Si . For example, ``ruiz" is a substring of ``ruizhang", and ``rzhang" is not a substring of ``ruizhang".
 

Input
The first line contains an integer  t (1t50)  which is the number of test cases.
For each test case, the first line is the positive integer  n (1n500)  and in the following  n  lines list are the strings  S1,S2,,Sn .
All strings are given in lower-case letters and strings are no longer than  2000  letters.
 

Output
For each test case, output the largest label you get. If it does not exist, output  1 .
 

Sample Input
  
  
4 5 ab abc zabc abcd zabcd 4 you lovinyou aboutlovinyou allaboutlovinyou 5 de def abcd abcde abcdef 3 a ba ccc
 

Sample Output
  
  
Case #1: 4 Case #2: -1 Case #3: 4 Case #4: 3
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5932  5931  5930  5929  5928 
 

Statistic |  Submit |  Discuss |  Note


三个方法不用剪枝似乎都会超时,

剪枝方法:加入a是b的子串,那么考虑c串是否能作为答案时,不用考虑a,只用考虑b。

因为如果b不是c的子串,c已经可以作为答案,自然不用考虑a。如果b是c的子串,那么a自然也是c的子串,并无任何帮助。

1.find()

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn=500    ;
string s[maxn+5];
int n,T;
bool vis[maxn+10];


int main()
{
    std::ios::sync_with_stdio(false);
   int T,kase=0;cin>>T;
   while(T--)
   {
       cin>>n;
       for1(i,n)  cin>>s[i];
       int ans=-1;
       mes(vis,0,n+1);
       for(int i=1;i<=n;i++)
       {
          for1(j,i-1) if(!vis[j])
          {
              if(s[i].find(s[j])==string::npos)
              {
                ans=i;
                break;
              }
              else
              {
                  vis[j]=1;
              }
          }
       }
       printf("Case #%d: %d\n",++kase,ans);
   }
   return 0;
}



2.strstr()

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn=500    ;
char s[maxn+5][2010];
int n;
bool vis[maxn+10];


int main()
{
   int T,kase=0;scanf("%d",&T);
   while(T--)
   {
       scanf("%d",&n);
       for1(i,n)  scanf("%s",s[i]);
       int ans=-1;
       mes(vis,0,n+1);
       for(int i=1;i<=n;i++)
       {
          for1(j,i-1) if(!vis[j])
          {
              if(!strstr(s[i],s[j]))
              {
                ans=i;
                break;
              }
              else
              {
                  vis[j]=1;
              }
          }
       }
       printf("Case #%d: %d\n",++kase,ans);
   }
   return 0;
}



3.KMP

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn=500    ;
char s[maxn+5][2010];
int n,nex[2010];
bool vis[maxn+10];

void getnex(char *P)
{
    nex[0]=nex[1]=0;
    int len=strlen(P);
    for(int i=1;i<len;i++)
    {
        int j=nex[i];
        while(j&&P[j]!=P[i])  j=nex[j];
        nex[i+1]= P[j]==P[i]?j+1:0;
    }
}


bool match(char* T,char *P)
{
    int j=0;
    int L=strlen(T),len=strlen(P);
    for(int i=0;i<L;i++)
    {
        while(j&&T[i]!=P[j]) j=nex[j];

        if(T[i]==P[j])  j++;

        if(j==len)  return true;
    }

    return false;
}
bool find(char *T,char *P)
{
      getnex(P);
      return match(T,P);

}
int main()
{
   int T,kase=0;scanf("%d",&T);
   while(T--)
   {
       scanf("%d",&n);
       for1(i,n)  scanf("%s",s[i]);
       int ans=-1;
       mes(vis,0,n+1);
       for(int i=1;i<=n;i++)
       {
          for1(j,i-1) if(!vis[j])
          {
              if(!find(s[i],s[j]))
              {
                ans=i;
                break;
              }
              else
              {
                  vis[j]=1;
              }
          }
       }
       printf("Case #%d: %d\n",++kase,ans);
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值