hdu 5573 Binary Tree 构造


题意:给出一棵二叉树,第一层的结点是权值是1,对于权值为k的结点,他的左儿子结点是2*k,右儿子结点是2*k+1


现在给出一个N和一个K,要求从第一层开始走到第K层,不能回头(就是走K-1),所经过的结点必须加上或者减去相应


结点的权值,最终使得权值和为0。





Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 869    Accepted Submission(s): 510
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is  1 . Say  froot=1 .

And for each node  u , labels as  fu , the left child is  fu×2  and right child is  fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another  N  years, only if he could collect exactly  N  soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node  x , the number at the node is  fx  (remember  froot=1 ), he can choose to increase his number of soul gem by  fx , or decrease it by  fx .

He will walk from the root, visit exactly  K  nodes (including the root), and do the increasement or decreasement as told. If at last the number is  N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given  N K , help the King find a way to collect exactly  N  soul gems by visiting exactly  K  nodes.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case contains two integers  N  and  K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

  1T100 .

  1N109 .

  N2K260 .
 

Output
For every test case, you should output " Case #x:" first, where  x  indicates the case number and counts from  1 .

Then  K  lines follows, each line is formated as 'a b', where  a  is node label of the node the frog visited, and  b  is either '+' or '-' which means he increases / decreases his number by  a .

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

Sample Input
  
  
2 5 3 10 4
 

Sample Output
  
  
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5932  5931  5930  5929  5928 
 

Statistic |  Submit |  Discuss |  Note


解法:


容易想到一种方法就是都取2的倍数:1,2,4,...2^(k-1)。先算出和为S,然后减去一些结点权值和的2倍最后凑成N。


但是有个问题就是如果差值为奇数如何处理,奇数意味着不是任何整数的两倍。


处理就是将最后一个结点变成2^(k-1)+1。这样就可以将差值变为偶数,然后可以得到负权值需要凑成的数。


这个数的二进制表示就暴露了第几层应该取负权值,而且你会发现最后第K层一定是正。



#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

#define mem(a,x)  memset(a,x,sizeof a)
typedef long long ll;
int N,K;
bool mns[70];
int main()
{
   std::ios::sync_with_stdio(false);
   int T,kase=0;cin>>T;
   bool move;
   while(T--)
   {

       cin>>N>>K;move=0;
       mem(mns,0);
       printf("Case #%d:\n",++kase);

       ll S=pow(2,K)-1+0.5;
       ll delta=S-N;
       if( delta&1 )  {move=1;delta++;}
       delta/=2;

       for(ll i=0,s=1; delta ;i++,s<<=1)
       {
           if(delta&s)
           {
               delta^=s;
               mns[i]=1;
           }
       }

       ll s=1;
       for(ll i=0;i<K-1;i++,s<<=1)
       {
           printf("%lld ",s);
            putchar(mns[i]?'-':'+');
           putchar('\n');
       }
       if(move) s++;
       printf("%lld +\n",s);
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值