1012 The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A
思路

题目给N个学生的C\M\E的成绩,再根据这三门成绩分别得到他们的平均分,再分别对相应科目排名,都会有一个排名,也会有一个最高的名次。有M个查询,输出该学生最高的一科排名和对应的字母,若存在相同排名的科目,则按照A > C > M > E输出最高的排名,若不存在则输出N/A。

建立结构体存储学生的成绩、id号、每科的排名、最好一科排名的下标。

排名并列应该1、1、3、4、5,而不是1、1、2、3、4,否则会有一个测试点不过

平均分是四舍五入的,所以需要按照+0.5后取整,保证是四舍五入的

存储的时候就按照ACME的顺序存储可以简化程序逻辑


C++:

#include "cstdio"
#include "algorithm"
#include "cmath"
#include "iostream"
using namespace std;

struct MyStruct
{
	int id;//id号
	int score[4];//四项成绩
	int rank[4];//四项排名
	int best;//最好排名下标
}stu[2001];

char course[5]={'A','C','M','E'};

int sum(MyStruct stu){
	int sum=0;
	for (int i=1;i<4;i++)
	{
		sum+=stu.score[i];
	}
	return sum;
}

int flag=-1;
bool cmp(MyStruct a,MyStruct b){
	return a.score[flag]>b.score[flag];
}

int exist[1000001];//标记存入的id

int main(){
	int n,m;
	cin>>n>>m;
	fill(exist,exist+1000000,-1);
	//读入N个学生成绩 并计算平均分
	for(int i=0;i<n;i++){
		cin>>stu[i].id>>stu[i].score[1]>>stu[i].score[2]>>stu[i].score[3];
		stu[i].score[0]=sum(stu[i])/3.0+0.5;
	}
	//排名
	for (flag=0;flag<4;flag++)
	{
		sort(stu,stu+n,cmp);
		stu[0].rank[flag]=1;//记录当前flag成绩下的第一名
		for (int i=1;i<n;i++)
		{
			if (stu[i].score[flag]==stu[i-1].score[flag])
			{
				stu[i].rank[flag]=i;//排名相同的情况
			}else{
				stu[i].rank[flag]=i+1;//记录当前flag成绩下的其余排名
			}
		}
	}
	//找出排名最高的成绩的下标
	for (int i=0;i<n;i++)
	{
		int a=0;
		for (int j=1;j<4;j++)
		{
			if (stu[i].rank[j]<stu[i].rank[a])
			{
				a=j;//小于它才更新
			}
		}
		stu[i].best=a;
		exist[stu[i].id]=i;//标记这个已存入 记录其在stu中的下标
	}
	int temp=0;
	for (int i=0;i<m;i++)
	{
		cin>>temp;
		if (exist[temp]!=-1)
		{
			int x=exist[temp];
			cout<<stu[x].rank[stu[x].best]<<" "<<course[stu[x].best]<<endl;
		}else{
			cout<<"N/A"<<endl;
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
下面这个代码报错了,应该怎么改: %%Matlab Genetic Algorithm for Sin Prediction clear; clc; %population size Npop=50; %create the population Pop=rand(Npop,1)*2*pi; %define fitness fit=@(x) sin(x); %fitness score score=fit(Pop); %maximum number of generations maxgen=100; %weights w=0.7; %probability p_crossover=0.9; p_mutation=0.2; %loop for number of generations for gen=1:maxgen %ranking %rank the population in descending order [~,rank]=sort(score); %rank the population in ascending order rank=flipud(rank); %normalised rank NormalisedRank=rank/sum(rank); %selection %cumulative sum of the normalised rank cumulativeSum=cumsum(NormalisedRank); %randomly select the two parents %from the populations based on their %normalised rank randnum=rand; parent1=find(cumulativeSum>randnum,1); randnum=rand; parent2=find(cumulativeSum>randnum,1); %crossover %randomly select the crossover point pc=randi([1 Npop-1]); %create the offsprings offspring1=[Pop(parent1,1:pc) Pop(parent2,pc+1:end)]; offspring2=[Pop(parent2,1:pc) Pop(parent1,pc+1:end)]; %perform crossover with a probability if(rand<p_crossover) Pop=[Pop; offspring1; offspring2]; end %mutation %randomly select the point of mutation pm=randi([1 Npop]); %mutate the value under the chosen point Pop(pm)=rand*2*pi; %perform mutation with a probability if (rand<p_mutation) Pop(pm)=rand*2*pi; end %evaluate new population score=fit(Pop); %elitism %sort the population in ascending order %of their fitness score [score,rank]=sort(score); elite=Pop(rank(1),:); Pop(rank(Npop),:)=elite; %replace old population Pop=Pop(1:Npop,:); end %print the best solution disp('Best Solution: '); disp(elite);
02-06

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值