Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
- The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
- Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
- Customer[i] will take T[i] minutes to have his/her transaction processed.
- The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer~1~ is served at window~1~ while customer~2~ is served at window~2~. Customer~3~ will wait in front of window~1~ and customer~4~ will wait in front of window~2~. Customer~5~ will wait behind the yellow line.
At 08:01, customer~1~ is done and customer~5~ enters the line in front of window~1~ since that line seems shorter now. Customer~2~ will leave at 08:02, customer~4~ at 08:06, customer~3~ at 08:07, and finally customer~5~ at 08:10.
Input
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.
Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry
思路
有N个窗口(<=20)、每个窗口可以站M个人(<=10)、总共有K个客人(<=1000)、要查询Q个客人办完业务的时间(<=1000)。
每个客人办业务时间是不同的,银行8:00开始营业,17:00下班,超过17:00完成的业务要打印“sorry”。用队列解决。
C++:
#include "cstdio"
#include "queue"
#include "vector"
#include "iostream"
using namespace std;
struct MyStruct
{
MyStruct(){
this->endtime=0;
this->poptime=0;
}
int poptime,endtime;//队列队首结束服务的时间 队尾结束服务的时间
queue<int> q;//每个窗口的队列
};
int main(){
int n,m,k,q;
cin>>n>>m>>k>>q;
vector<MyStruct> window(n+1);//n个窗口
vector<int> time(k + 1), result(k + 1);//每个人耗时 离开时间
vector<bool> sorry(k+1,false);//记录哪些客户是需要输出sorry的
for(int i=1;i<=k;i++){
cin>>time[i];
}
int index=1;//客户标号
//先把窗口占满
for (int i=1;i<=m;i++)//每个窗口前有m个空位
{
for (int j=1;j<=n;j++)//共有n个窗口
{
if (index<=k){
window[j].q.push(time[index]);//客户index进入j窗口
if (window[j].endtime>=540)//刚好17:00
{
sorry[index]=true;
}
window[j].endtime+=time[index];
if (i==1)
{
window[j].poptime=window[j].endtime;//当是这个窗口前的第一个客户 则这个窗口的poptime就是结束的endtime
}
result[index]=window[j].endtime;
index++;
}
}
}
//考虑剩余在排队的客户
while (index<=k)
{
int tempmin = window[1].poptime, tempwindow = 1;
for(int i = 2; i <= n; i++) {
if(window[i].poptime < tempmin) {//找出最早结束的队伍首
tempwindow = i;
tempmin = window[i].poptime;
}
}
window[tempwindow].q.pop();
window[tempwindow].q.push(time[index]);//最早空出位置的队伍加入新的客户
window[tempwindow].poptime += window[tempwindow].q.front();
if(window[tempwindow].endtime >= 540)
sorry[index] = true;
window[tempwindow].endtime += time[index];
result[index] = window[tempwindow].endtime;
index++;
}
for(int i = 1; i <= q; i++) {
int query, minute;
cin>>query;
minute = result[query];
if(sorry[query] == true) {
cout<<"Sorry"<<endl;
} else {
printf("%02d:%02d\n",(minute + 480) / 60, (minute + 480) % 60);
}
}
return 0;
}