PTA1014——1014 Waiting in Line (30 point(s))

1、题目要求
Description

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
    The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry
2、解答
#include<iostream>
#include<vector>
#include<cstdio>
#include<iostream>

using std::cin;
using std::cout;
using std::endl;
using std::vector;

//表示排队顾客的数据结构,包含其开始办理时间和需要的办理时间
struct c_time{
    int beg_time;
    int proc_time;
    c_time(int beg = 0, int proc = 0): beg_time(beg),proc_time(proc){}
};
//表示窗口的数据结构,indx表示当前窗口队伍最前面的人员的索引,end_time当前队伍中最后一人办理完成的时间;
//line表示一个队列,存储排在当前窗口顾客在顾客vector的index
struct l_time{
    int indx;
    int end_time;
    vector<int> line;
    l_time(int in, int end): indx(in),end_time(end){}
};

//初始化窗口队列的函数,也就是8点上班时,黄线前面队伍的形成
void iniWindows(vector<c_time> &customers, vector<l_time> &windows, int num);
//通过比较确认,下一个顾客排在哪一个队列中
int minWindow(const vector<c_time> &customers, vector<l_time> &windows);
//随着业务办理,后面的顾客排入队列中的函数
int updateWindows(vector<c_time> &customers, vector<l_time> &windows, int index);
//输出函数,输出前时间是按8点为0,按分钟计时的;此函数将时间转换为要求的输出形式输出
void printTime(const vector<c_time> &customer, int indx, int firstNoLined);
int main()
{
    //变量定义和输入数据前两行,将所有顾客数据用vector来表示。
    int N, M, K, Q;
    int proc_time, indx;
    cin >> N >> M >> K >> Q;
    vector<c_time> customers;
    for(int i = 0; i < K; ++i)
    {
        cin >> proc_time;
        customers.emplace_back(0, proc_time);
    }
    vector<l_time> windows(N,{0,0});
    
    int firstNoLined;   //记录第一个在下班前还未排入队伍的人员的index

    //根据题目要求将所有的顾客排队
    if( K > M * N)
    {
        iniWindows(customers,windows, M * N);
        firstNoLined =  updateWindows(customers,windows, M * N);
    }
    else
    {
        iniWindows(customers,windows, K);
    }
       
    //输出数据
    for(int i = 0; i < Q; ++i)
    {
        cin >> indx;
        printTime(customers,indx -1,firstNoLined);
    }

}

void iniWindows(vector<c_time> &customers, vector<l_time> &windows, int num)
{
    int index, size = windows.size();
    for(int i = 0; i < num; ++i)
    {
        index = i % size;
        customers[i].beg_time = windows[index].end_time;
        windows[index].line.push_back(i);
        windows[index].end_time += customers[i].proc_time;
    }
}
int minWindow(const vector<c_time> &customers,vector<l_time> &windows)
{
    int size = windows.size();
    int min = 540, index = -1;
    for( int i = 0; i < size; ++i)
    {
        int index_c = windows[i].line[windows[i].indx];
        if( customers[index_c].beg_time + customers[index_c].proc_time < min)
        {
            min = customers[index_c].beg_time + customers[index_c].proc_time;
            index = i;
        }
    }
    if( index != -1)
        ++windows[index].indx;
    return index;
}
int updateWindows(vector<c_time> &customers, vector<l_time> &windows, int index)
{
    int N = customers.size();
    for(int i = index; i < N; ++i)
    {
        int window_num = minWindow(customers,windows);
        if( window_num == -1)
        {
            N = i;
            break;
        }          
        customers[i].beg_time = windows[window_num].end_time;
        windows[window_num].line.push_back(i);
        windows[window_num].end_time += customers[i].proc_time;
    }
    return N;
}
void printTime(const vector<c_time> &customer, int index, int firstNoLined)
{
    int time = index < firstNoLined ? customer[index].beg_time:540;
    if( time >= 540)
        cout << "Sorry" << endl;
    else
    {
        int hh = (time+ customer[index].proc_time) / 60 + 8;
        int mm = (time+ customer[index].proc_time) % 60;
        printf("%02d:%02d\n",hh,mm);
    }
    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值