1021 Deepest Root (25)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components
思路:

给出N个结点,N-1条边,如果能构成树,则输出使树高最大的根结点。

因为是无向图,避免回头路,要记录。

进行两次深度优先遍历,第一次是检查连通情况,并且处理好只有一个结点的情况,如果只有一棵树那进行第二次,找出使树高最大的根结点

C++:

#include "iostream"
#include "vector"
#include "set"
#include "algorithm"
using namespace std;
vector <vector<int>> v;
int n, maxheight = 0;
bool visit[10010];
set<int> s;
vector<int> temp;
void dfs(int node, int height) {
	if(height > maxheight) {
		temp.clear();
		temp.push_back(node);
		maxheight = height;
	} else if(height == maxheight){
		temp.push_back(node);
	}
	visit[node] = true;
	for(int i = 0; i < v[node].size(); i++) {
		if(visit[v[node][i]] == false)
			dfs(v[node][i], height + 1);
	}
}
int main() {
	scanf("%d", &n);
	v.resize(n + 1);
	int a, b, cnt = 0, s1 = 0;
	for(int i = 0; i < n - 1; i++) {
		scanf("%d%d", &a, &b);
		v[a].push_back(b);
		v[b].push_back(a);
	}
	//检查连通 处理只有一个结点的情况
	for(int i = 1; i <= n; i++) {
		if(visit[i] == false) {
			dfs(i, 1);
			if(i == 1) {
				if (temp.size() != 0) s1 = temp[0];
				for(int j = 0; j < temp.size(); j++)
					s.insert(temp[j]);
			}
			cnt++;
		}
	}
	if(cnt >= 2) {
		printf("Error: %d components", cnt);
	} else {
		temp.clear();
		maxheight = 0;
		fill(visit, visit + 10010, false);
		dfs(s1, 1);
		for(int i = 0; i < temp.size(); i++)
			s.insert(temp[i]);
		for(auto it = s.begin(); it != s.end(); it++)
			printf("%d\n", *it);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值