Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
思路:
计算分数相加。
最大公约数 return b==0?a:fcd(b,a%b);
C++:
#include<cstdio>
#include<algorithm>
using namespace std;
struct Fraction{
long long up;
long long down;
};
long long gcd(long long a,long long b){//a b最大公约数
return !b?a:gcd(b,a%b);
}
Fraction reduction(Fraction a){//化简
if(a.down<0){//分母为负数 分子分母皆变成相反数
a.up=-a.up;
a.down=-a.down;
}
if(a.up==0)a.down=1;
else{
int d=gcd(abs(a.up),abs(a.down));//取绝对值
a.up/=d;
a.down/=d;
}
return a;
}
Fraction add(Fraction f1,Fraction f2){
Fraction result;
result.up=f1.up*f2.down+f2.up*f1.down;
result.down=f1.down*f2.down;
return reduction(result);
}
void showResult(Fraction r){
reduction(r);
if(r.down==1)printf("%lld\n",r.up);
else if(abs(r.up)>r.down){
printf("%lld %lld/%lld\n",r.up/r.down,abs(r.up)%r.down,r.down);
}else{
printf("%lld/%lld\n",r.up,r.down);
}
}
int main(){
int n;
scanf("%d",&n);
Fraction sum,temp;
sum.up=0;
sum.down=1;
for(int i=0;i<n;i++){
scanf("%lld/%lld",&temp.up,&temp.down);
sum=add(sum,temp);
}
showResult(sum);
return 0;
}