1113 Integer Set Partition(25 分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

思路:

好像考研题里见过类似的。这个很好比较,记录好累加和就好。

C++:

#include "cstdio"
#include "algorithm"
#include "iostream"
#include "vector"
#include "cmath"
using namespace std;
vector<int> record;
bool cmp(int a,int b){
	return a>b;
}
const int inf=999999999;
int dis[100010]={0};
int main(){
	int n;
	scanf("%d",&n);
	record.resize(n+1);
	for (int i=1;i<=n;i++){
		scanf("%d",&record[i]);
	}
	sort(record.begin()+1,record.end(),cmp);
	for(int i=1;i<=n;i++)
		dis[i]=dis[i-1]+record[i];
	int s1=0,s2=0,n1=0,n2=0;
	int maxs=-1,minn=inf;
	for (int i=1;i<=n;i++)
	{
		s1+=record[i];
		s2=dis[n]-s1;
		n1=i;
		n2=n-i;
		if (abs(n1-n2)<minn)
		{
			minn=abs(n1-n2);
			maxs=abs(s1-s2);
		}else if(abs(n1-n2)==minn)
		{
			if (abs(s1-s2)>maxs)
			{
				maxs=abs(s1-s2);
			}
		}
	}
	printf("%d %d",minn,maxs);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值