stl-map的一道很好的题目

Damn Single (25)

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888

思路:pat甲级的一道题目,个人的第一次看到用map容器的用法,map的用法主要用于标记,这道题个人感觉很不错,运用map,很好说明map的一些常用的用法。用法在代码注释。

#include <cstdio>  
#include <cstring>  
#include <vector>  
#include <map>  
#include <algorithm>  
#include <iostream>  
using namespace std;  
int main(){  
    int n,count=0;  
    string a,b;  
    map<string,string> c;  
    map<string,int> d;  
    vector<string> re;  
    cin>>n;  
    for(int i=1;i<=n;i++){  
        cin>>a>>b;  
        c.insert(pair<string,string>(a,b));//对a和b进行插入,说明a是key,b是value;
        c.insert(pair<string,string>(b,a));  //想反的在进行一个插入,a与b此时连在一起的感觉。
    }  
    cin>>n;  
    for(int i=1;i<=n;i++){  
        cin>>a;  
        d[a]=1;  //对a进行标记;
    }  
    int flag=0;  
    map<string,int> ::iterator it;  
    for(it=d.begin();it!=d.end();it++){  
        if(d.count(c[it->first])==0){ //count函数说明value有没有出现,c【}it-》first 】的值是夫妻对方;主要要明白这里的it->first。
            count++;  
            re.push_back(it->first); //map中的it->first是
            自动排序的。
               }  
    }  
    cout<<count<<endl;  
    for(int i=0;i<re.size();i++){  
        cout<<re.at(i)<<(i==re.size()-1?'\n':' ');  
    }  
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值