zoj-3950

How Many Nines

Time Limit: 1 Second       Memory Limit: 65536 KB

If we represent a date in the format YYYY-MM-DD (for example, 2017-04-09), do you know how many 9s will appear in all the dates between Y1-M1-D1 and Y2-M2-D2 (both inclusive)?

Note that you should take leap years into consideration. A leap year is a year which can be divided by 400 or can be divided by 4 but can't be divided by 100.

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow. For each test case:

The first and only line contains six integers Y1M1D1Y2M2D2, their meanings are described above.

It's guaranteed that Y1-M1-D1 is not larger than Y2-M2-D2. Both Y1-M1-D1 and Y2-M2-D2 are between 2000-01-01 and 9999-12-31, and both dates are valid.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case, you should output one line containing one integer, indicating the answer of this test case.

Sample Input
4
2017 04 09 2017 05 09
2100 02 01 2100 03 01
9996 02 01 9996 03 01
2000 01 01 9999 12 31
Sample Output
4
2
93
1763534
Hint

For the first test case, four 9s appear in all the dates between 2017-04-09 and 2017-05-09. They are: 2017-04-09 (one 9), 2017-04-19 (one 9), 2017-04-29 (one 9), and 2017-05-09 (one 9).

For the second test case, as year 2100 is not a leap year, only two 9s appear in all the dates between 2100-02-01 and 2100-03-01. They are: 2017-02-09 (one 9) and 2017-02-19 (one 9).

For the third test case, at least three 9s appear in each date between 9996-02-01 and 9996-03-01. Also, there are three additional nines, namely 9996-02-09 (one 9), 9996-02-19 (one 9) and 9996-02-29 (one 9). So the answer is 3 × 30 + 3 = 93.


Author:  WENG, Caizhi

Source: The 17th Zhejiang University Programming Contest Sponsored by TuSimple

解析:题意就是求给你两个年份问之间出现几个9.

看到T=1e5,其实不用怕超时,就是因为测试数据多,所以我们可以一次性算出从2000年到当前的9个个数,后面直接调用就可以。

#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector> 
#include<set>
#include<map>
#include<queue>
using namespace std;

int a[14]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int b[14]={0,31,29,31,30,31,30,31,31,30,31,30,31};

int s[10000][13][32];

bool leapYear(int y)
{
	if((y%4==0&&y%100!=0)||y%400==0)return true;
	return false;
}
void f()
{
	s[2000][1][1]=0;
	int ans=0,l=0;
	for(int y=2000; y<10000; y++)
	{
		if(leapYear(y))
		{
			for(int m=1; m<13; m++)
			{
				for(int d=1; d<=b[m]; d++)
				{
					int x=y*10000+m*100+d;
					l=0;
					while(x>0)
					{
						int z=x%10;
						x/=10;
						if(z==9)l++;
					}
					s[y][m][d]=ans+l;
					ans=s[y][m][d];
				}
			}
		}
		else
		{
			for(int m=1; m<13; m++)
			{
				for(int d=1; d<=a[m]; d++)
				{
					int x=y*10000+m*100+d;
					l=0;
					while(x>0)
					{
						int z=x%10;
						x/=10;
						if(z==9)l++;
					}
					s[y][m][d]=ans+l;
					ans=s[y][m][d];
				}
			}
		}
	}
}
int main()
{
	int t;
	f();
	scanf("%d",&t);

	while(t--)
	{
		int y1,m1,d1,y2,m2,d2;
		scanf("%d%d%d%d%d%d",&y1,&m1,&d1,&y2,&m2,&d2);
		int x=y1*10000+m1*100+d1;
		int ans=0;
		while(x>0)
		{
			int z=x%10;
			x/=10;
			if(z==9)ans++;
		}
		printf("%d\n",s[y2][m2][d2]-s[y1][m1][d1]+ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值