Queen Collision

Lots of time has been spent by computer science students dealing with queens on a chess board. Two queens on a chessboard collide if they lie on the same row, column or diagonal, and there is no piece between them. Various sized square boards and numbers of queens are considered. For example, Figure 1, with a 7 × 7 board, contains 7 queens with no collisions. In Figure 2 there is a 5 × 5 board with 5 queens and 4 collisions. In Figure 3, a traditional 8 × 8 board, there are 7 queens and 5 collisions.

     On an n × n board, queen positions are given in Cartesian coordinates (x, y) where x is a column number, 1 to n, and y is a row number, 1 to n. Queens at distinct positions (x1, y1) and (x2, y2) lie on the same diagonal if (x1 − x2) and (y1 − y2) have the same magnitude. They lie on the same row or column if x1 = x2 or y1 = y2, respectively

     In each of these cases the queens have a collision if there is no other queen directly between them on the same diagonal, row, or column, respectively. For example, in Figure 2, the collisions are between the queens at (5, 1) and (4, 2), (4, 2) and(3, 3), (3, 3) and (2, 4), and finally (2, 4) and (1, 5). In Figure 3, the collisions are between the queens at (1, 8) and (4, 8), (4, 8) and (4, 7), (4, 7) and (6, 5),(7, 6) and (6, 5), and finally (6, 5) and (2, 1). Your task is to count queen collisions.

     In many situations there are a number of queens in a regular pattern. For instance in Figure 1 there are 4 queens in a line at (1,1), (2, 3), (3, 5), and (4, 7). Each of these queens after the first at (1, 1) is one to the right and 2 up from the previous one. Three queens starting at (5, 2) follow a similar pattern. Noting these patterns can allow the positions of a large number of queens to be stated succinctly.

Input

The input will consist of one to twenty data sets, followed by a line containing only ‘0’. The first line of a dataset contains blank separated positive integers n g, where n indicates an n×n board size, and g is the number of linear patterns of queens to be described, where n < 30000, and g < 250. The next g lines each contain five blank separated integers, k x y s t, representing a linear pattern of k queens at locations (x + i ∗ s, y + i ∗ t), for i = 0, 1, . . . , k − 1. The value of k is positive. If k is 1, then the values of s and t are irrelevant, and they will be given as ‘0’. All queen positions will be on the board. The total number of queen positions among all the linear patterns will be no more than n, and all these queen positions will be distinct.

Output

There is one line of output for each data set, containing only the number of collisions between the queens.

The sample input data set corresponds to the configuration in the Figures.

Take some care with your algorithm, or else your solution may take too long.

Sample Input

7 2

4 1 1 1 2

3 5 2 1 2

5 1

5 5 1 -1 1

8 3

1 2 1 0 0

3 1 8 3 -1

3 4 8 2 -3

0

Sample Output

0

4

5

题意:给你每一个皇后的位置,xx=x+i*s,yy=y+i*t;求出碰撞次数。

碰撞定义:位于同一行,同一列,同一对角线

解析:直接枚举每一个皇后的位置进行判断肯定T,所以我们要转换思路。我们可以枚举每一个可以发生碰撞的点,行列对角线,要是有行列对角线有两个皇后及以上,说明会发生碰撞。碰撞+1;

#include<set>
#include<map>
#include<list>
#include<queue>
#include<cmath>
#include<stack>
#include<vector>
#include<cstdio>
#include<string>
#include<bitset>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}
const int maxn=30010;
int r[maxn],c[maxn],d1[2*maxn],d2[2*maxn];
int main()
{
	int n,g;
	while(~scanf("%d",&n),n)
	{
		scanf("%d",&g);
		mem(r,0);
		mem(c,0);
		mem(d1,0);
		mem(d2,0);
		int k,x,y,s,t;
		ll cnt=0;
		while(g--)
		{
			scanf("%d%d%d%d%d",&k,&x,&y,&s,&t);
			for(int i=0; i<k; i++)
			{
				int xx=x+i*s;
				int yy=y+i*t;
				r[xx]++;
				if(r[xx]>=2)cnt++;
				
				c[yy]++;
				if(c[yy]>=2)cnt++;
				
				d1[xx+yy]++;
				if(d1[xx+yy]>=2)cnt++;
				
				d2[xx-yy+n]++;
				if(d2[xx-yy+n]>=2)cnt++;
			}
		}
		printf("%lld\n",cnt);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值