1020 Tree Traversals

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题意:已知postOrder(后序遍历)和inOrder(中序遍历),输出它的层次遍历。

解析:这里需要指针,不懂结构指针的还是需要去复习复习。毕竟很重要。

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

typedef struct TreeNode* Tree;
struct TreeNode{
	Tree left;
	Tree right;
	int num;
};

const int maxn=40;
int postOrder[maxn];
int inOrder[maxn];
int n,cur;

int findRootIndex(int rootNum)
{
	for(int i=0; i<n; i++)
	{
		if(inOrder[i]==rootNum)return i;
	}
	return -1;
}
Tree CreatTree(int left,int right)
{
	if(left>right)return NULL;
	int root=postOrder[cur];
	cur--;
	int rootIndex=findRootIndex(root);
	Tree T=(Tree)malloc(sizeof(struct TreeNode));
	T->num=root;
	if(left==right)
	{
		T->left=NULL;
		T->right=NULL;
	}
	else
	{
		//此处为什么要先建右子树呢?原因如下:
		//因为cur是postOrder中后面开始的,也就是每个子树根节点,也从后数,即是右子树的遍历序列再是
		//左子树的遍历序列。要是先建左子树,cur--,此时int root=postOrder[cur];是左子树的根,但是
		//根据遍历序列规则知,肯定不对。所以cur应该是先属于右子树。
		//我解释 的很奇怪,主要还是自己理解吧 
		T->right=CreatTree(rootIndex+1,right);
		T->left=CreatTree(left,rootIndex-1);
	}
	return T;
}

void bfs(Tree T)
{
	queue<Tree> q;
	q.push(T);
	bool firstout=true;
	
	while(!q.empty())
	{
		Tree t=q.front();q.pop();
		if(firstout)
		{
			printf("%d",t->num);
			firstout=false;
		}
		else
		{
			printf(" %d",t->num);
		}
		if(t->left!=NULL)
		{
			q.push(t->left);
		}
		if(t->right!=NULL)
		{
			q.push(t->right);
		}
	}
}
int main()
{
	scanf("%d",&n);
	for(int i=0; i<n; i++)
	{
		scanf("%d",&postOrder[i]);
	}
	for(int i=0; i<n; i++)
	{
		scanf("%d",&inOrder[i]);
	}
	cur=n-1;
	
	Tree T=CreatTree(0,cur);
	bfs(T);
	puts("");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值