1023 Have Fun with Numbers (20 分)
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
希望可以一直是“A货”
#include<bits/stdc++.h>
using namespace std;
#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}
string s,ds;
int num[10];
int dnum[10];
int a[30];
int main()
{
cin>>s;
for(int i=0; i<s.size(); i++)
{
num[s[i]-'0']++;
}
int t=0,cnt=0;
for(int i=s.size()-1; i>=0; i--)
{
int x=(s[i]-'0')*2+t;
a[cnt++]=x%10;
t=x/10;
}
if(t==1)
{
printf("No\n");
a[cnt++]=1;
}
else
{
for(int i=0; i<cnt; i++)
{
dnum[a[i]]++;
}
bool flag=false;
for(int i=0; i<10; i++)
{
if(num[i]!=dnum[i])flag=true;
}
if(!flag)
printf("Yes\n");
else printf("No\n");
}
for(int i=cnt-1; i>=0; i--)
{
printf("%d",a[i]);
}
puts("");
return 0;
}